POJ-3368 Frequent values

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains nintegers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input
10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0
Sample Output
1
4
3

// RMQ在线查询

#include <cstdio>
#include <algorithm>
#include <cmath>

#define MAX 100010

using namespace std;

int maxsum[MAX][20];
int f[MAX];
int a[MAX];
int n, q;

void RMQ( int n ) { //预处理->O(nlogn)
    for( int i = 1; i <= n; i++ ) {
        maxsum[i][0] = f[i];
    }

    for( int j = 1; j < 20; ++j )
        for( int i = 1; i <= n; ++i )
            if( i + (1 << j) - 1 <= n ) {
                maxsum[i][j] = max( maxsum[i][j - 1], maxsum[i + (1 << (j - 1))][j - 1] );
            }
}

int query( int left, int right ) {
    if( left > right ) return 0;
    int k = (int)(log( right - left + 1.0 ) / log( 2.0 ));
    int maxres = max( maxsum[left][k], maxsum[right - ( 1 << k ) + 1][k] );
    return maxres;
}

int main() {
    while( scanf( "%d", &n ) ) {
        memset( a, 0, sizeof( a ) );
        memset( f, 0, sizeof( f ) );
        memset( maxsum, 0, sizeof( maxsum ) );
        if( n == 0 ) break;
        scanf( "%d", &q );

        for( int i = 1; i <= n; i++ ) {
            scanf( "%d", &a[i] );
            if( i == 1 ) f[1] = 1;
            else if( a[i] == a[i - 1] ) f[i] = f[i - 1] + 1;
            else f[i] = 1;
        }

        RMQ( n );

        while( q-- ) {
            int left, right;
            scanf( "%d%d", &left, &right );

            // 先寻找前半段满足连续相等值的位置,因为前半段可能会产生影响
            int t = left;
            while( t <= right && a[t] == a[t - 1] ) t++;
            int ans = query( t, right );    // 计算后半段
            ans = max( ans, t - left );     // 选两者最大值
            printf( "%d\n", ans );
        }
    }

    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值