POJ3368--Frequent values

3 篇文章 0 订阅
Frequent values
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 15249 Accepted: 5559

题意:某区间内出现最多的数出现的次数;

Description

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

Source

Ulm Local 2007

#include <iostream>
#include <cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
const int N= 1e5+5;
int n,m;
int value[N],cont[N],dp[N][19];
void RMQ()
{
    for(int i=1;i<=n;i++)
    {
        dp[i][0]=cont[i];
    }
    int k=log((double)(n+1))/log(2.0);
    for(int j=1;j<=k;j++)
    {
        for(int i=1;i+(1<<j)-1<=n;i++)
        {
            dp[i][j]=max(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
        }
    }
}
int RMQ(int L,int R)
{
    if(L>R)
        return 0;
    int k=log((double)(R-L+1))/log(2.0);
    return max(dp[L][k],dp[R-(1<<k)+1][k]);
}
int main()
{
      int a,b;
     while(scanf("%d",&n),n)
     {
         scanf("%d",&m);
         for(int i=1;i<=n;i++)
         {
             scanf("%d",&value[i]);
             if(i==1)
                cont[i]=1;
             else
             {
                 if(value[i]==value[i-1])
                    cont[i]=cont[i-1]+1;
                 else
                    cont[i]=1;
             }
         }
         RMQ();
         while(m--)
         {

             scanf("%d%d",&a,&b);
             int i=a+1;
             while(value[i]==value[a]&&i<=b)
                i++;
             int cnt=RMQ(i,b);
             cnt=max(cnt,i-a);
             printf("%d\n",cnt);
         }
     }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值