1107 Social Clusters——PAT甲级(并查集)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki​: hi​[1] hi​[2] ... hi​[Ki​]

where Ki​ (>0) is the number of hobbies, and hi​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

 solution:
 

#include<bits/stdc++.h>//并查集做法
using namespace std;
typedef long long ll;
#define endl '\n'
const int maxn=1e3+5;
int father[maxn];//并查集
int isroot[maxn];//选课对应根节点人数 
int course[maxn];//选课对象
int find1(int x)
{
	return x==father[x]?x:(father[x]=find1(father[x]));
}
void union1(int a,int b)
{
	int x=find1(a);
	int y=find1(b);
	if(x!=y)
	{
		father[y]=x;
	}
}
int main()
{
	int n;cin>>n;
	for(int i=1;i<=n;i++)
	{
		father[i]=i;
	}
	for(int i=1;i<=n;i++)
	{
		int k;
		scanf("%d:",&k);
		for(int j=0;j<k;j++)
		{
			int tmp;cin>>tmp;
			if(!course[tmp])course[tmp]=i;//如果这门课没有被人选择,则他的父节点为这个人
			union1(i,father[course[tmp]]);
			//第一种情况:
			//刚刚是第一个人选了这门课,那么等同于i与i的父节点相链接
			//第二种情况:
			//超过1人选了这门课,那么将轮到的这个人i与第一个选了这门课的人相链接 
		}
	}
	int ans=0;
	for(int i=1;i<=n;i++)
	{
		isroot[find1(i)]++;
	}
	for(int i=1;i<=n;i++)
	{
		if(isroot[i])ans++;
	}
	cout<<ans<<endl;
	sort(isroot+1,isroot+1+n,[](int a,int b)
	{
		return a>b;
	});
	for(int i=1;i<=ans;i++)
	{
		if(i!=1)cout<<' ';
		cout<<isroot[i];
	}
}

 参考:http://t.csdnimg.cn/5A7CL

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值