1051 Pop Sequence——PAT甲级(含大概讲解)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

 solution:
 

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int m,n,k;cin>>m>>n>>k;
    vector<vector<int> >a(k,vector<int>(n));
    for(int i=0;i<k;i++)for(int j=0;j<n;j++)cin>>a[i][j];
    for(int i=0;i<k;i++)
    {
        stack<int>s;s.push(0);//初始压入元素,方便
        bool flag=true;//判断是否正确
        int cnt=1;//数字下标,从1~n
        int j=0;//循环遍历每行元素下标
        while(1)
        {
            while(s.top()!=a[i][j])//栈头元素不等于当前遍历的数组
            {
                if(cnt<=n)s.push(cnt++);//压入元素
                if(s.size()-1>m)//栈元素数量超过最大存放量
                {
                    flag=false;
                    break;
                }
                if(cnt>n)break;//所有元素全部压入
            }
            if(!flag)break;
            while(s.top()==a[i][j])//栈头元素等于当前遍历数组
            {
                s.pop();//弹出栈头元素
                j++;//数组下标加一,标志该数组下一个元素
                if(j==n)break;//所有元素均遍历完成
            }
            if(j==n)break;//所有元素均遍历完成
            if(cnt>n && a[i][j]!=s.top())//所有元素全部压入而且栈头元素不匹配
            {
            	flag=false;
            	break;
			}
        }
        if(flag)cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }
}

 复盘一下:首先建立一个栈,每次匹配栈头都先压入0,因为0不可能被匹配,所以压入不影响结果且方便后续运算。之后定义cnt标志压入元素,j下标对应所匹配的元素下标。每轮循环中,如果无法对应,就一直压入元素直至可以匹配或者所有元素均压入。压入过程中如果栈容量超限,那么直接返回false,进入下一个判断。之后while循环判断栈头元素是否匹配,如果匹配则弹出栈头元素直至不匹配或者所有元素均弹出。最后一个判断if(cnt>n && a[i][j]!=s.top())是针对如同测试点2的数据:所有元素均压入而却栈头元素不匹配,那么返回false进入下一轮循环。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值