1105 Spiral Matrix——PAT甲级

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

 solution:
 

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int main()
{
	int t;
	cin>>t;
	vector<int>a(t);
	for(int i=0;i<t;i++)cin>>a[i];
	sort(a.begin(),a.end(),[](int a,int b)
	{
		return a>b;
	});
	int n,m;
	for(int i=floor(sqrt((double)t));i>=1;i--)
	{
		if(fmod((double)t/i,1.0)==0)
		{
			n=i;
			m=t/i;
			break;
		}
	}
	//cout<<n<<' '<<m;
	vector<vector<int> >ans(m,vector<int>(n));
	int cnt=0;
	int l=0,r=n-1,u=0,d=m-1;
	while(cnt<t)
	{
		for(int i=l;i<=r;i++)
		{
			ans[u][i]=a[cnt++];
		}
		if(cnt>=t)break;
		u++;
		for(int i=u;i<=d;i++)
		{
			ans[i][r]=a[cnt++];
		}
		if(cnt>=t)break;
		r--;
		for(int i=r;i>=l;i--)
		{
			ans[d][i]=a[cnt++];
		}
		if(cnt>=t)break;
		d--;
		for(int i=d;i>=u;i--)
		{
			ans[i][l]=a[cnt++];
		}
		if(cnt>=t)break;
		l++;
	}
	for(int i=0;i<m;i++)
	{
		for(int j=0;j<n;j++)
		{
			if(j)cout<<' ';
			cout<<ans[i][j];
		}
		cout<<endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值