关于整合php5,apache2.x,mysql中出现"无法载入 mysql 扩展,请检查 PHP 配置"的解决方法

关键点1:

php.ini 文件中的

extension=php_mbstring.dll

extension=php_gd2.dll

extension=php_mysql.dll

前面的注释需要去掉,这样让系统才知道需要加载这几个扩展dll。但是还需要让系统能找到这几个dll,

一种解决方法是把这几个dll,拷贝到系统目录下,系统目录可以在cmd下执行"path"命令可以看到。也可

以修改系统的path值,将包含这3个文件的文件夹添加到系统的path值里面。我个人认为修改path值对

未来的修改扩展升级更加的好。

 

关键点2:

修改extension_dir = "", 将这个参数的值设置为: php目录/ext ,比如如果你的php目录为F:/php5,那extension_dir = "F:/php5/ext"

 

关键点3:

修改apache下面的httpd.conf文件,添加下面这行

PHPIniDir  "F:/php5"

我的php目录是在F:/php5下,大家根据自己的系统情况修改这个值就是。

 

这个问题是php5特有的,php4的版本不存在。希望能节约大家的时间。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值