UVA 657 - The die is cast 深度搜索

  657 - The die is cast

InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that games of chance are pretty popular among their potential customers. Be it Monopoly, ludo or backgammon, most of these games involve throwing dice at some stage of the game.

Of course, it would be unreasonable if players were allowed to throw their dice and then enter the result into the computer, since cheating would be way to easy. So, instead, InterGames has decided to supply their users with a camera that takes a picture of the thrown dice, analyzes the picture and then transmits the outcome of the throw automatically.

For this they desperately need a program that, given an image containing several dice, determines the numbers of dots on the dice.

We make the following assumptions about the input images. The images contain only three dif- ferent pixel values: for the background, the dice and the dots on the dice. We consider two pixels connected if they share an edge - meeting at a corner is not enough. In the figure, pixels A and B are connected, but B and C are not.

A set S of pixels is connected if for every pair (a,b) of pixels in S, there is a sequence $a_1, a_2, \dots, a_k$ inS such that a = a1 and b = ak , and ai and ai+1 are connected for $1 \le i < k$.

We consider all maximally connected sets consisting solely of non-background pixels to be dice. `Maximally connected' means that you cannot add any other non-background pixels to the set without making it dis-connected. Likewise we consider every maximal connected set of dot pixels to form a dot.

Input 

The input consists of pictures of several dice throws. Each picture description starts with a line containing two numbers w and h, the width and height of the picture, respectively. These values satisfy $5 \leŸw,h \le 50$ .

The following h lines contain w characters each. The characters can be: ``.'' for a background pixel, ``*'' for a pixel of a die, and ``X'' for a pixel of a die's dot.

Dice may have different sizes and not be entirely square due to optical distortion. The picture will contain at least one die, and the numbers of dots per die is between 1 and 6, inclusive.

The input is terminated by a picture starting with w = h = 0, which should not be processed.

Output 

For each throw of dice, first output its number. Then output the number of dots on the dice in the picture, sorted in increasing order.

Print a blank line after each test case.

Sample Input 

30 15
..............................
..............................
...............*..............
...*****......****............
...*X***.....**X***...........
...*****....***X**............
...***X*.....****.............
...*****.......*..............
..............................
........***........******.....
.......**X****.....*X**X*.....
......*******......******.....
.....****X**.......*X**X*.....
........***........******.....
..............................
0 0

Sample Output 

Throw 1
1 2 2 4

题意: 给一张有很多个(至少一个)骰子的图片,判断骰子上的点数。这张图片有三种像素组成,分别是  ' . '表示背景, ' * '表示骰子, ' X '骰子中的点;两个像素共用一条边表示连接,而共用一角却不表示连接。

解题思路:两次深度搜索,先搜索筛子,再搜索筛子中有几个点。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>

using namespace std;

char mp[55][55];//存储地图
int vis[55][55];//标记是否被访问过
int s[110];//答案存储在这个数组中
struct node
{
    int x;
    int y;
} ls[3601],t,f;//bfs的队列


int bhx[] = {-1,0,1,0};
int bhy[] = {0,1,0,-1};//四个方向

int num = 0;//记录X的个数
int js;
int m,n;

void dfs(int x,int y)
{
    int i,a,b;
    vis[x][y] = 1;//标记X
    for(i = 0; i < 4; i++)
    {
        a = x + bhx[i];
        b = y + bhy[i];
        if(a >= 0 && a < n&& b >= 0 && b < m && mp[a][b] == 'X' && !vis[a][b])
        {
            dfs(a,b);
        }
    }
}

void bfs(int x,int y)
{
    int tp = 0,tl = 0,i;
    t.x = x;
    t.y = y;
    ls[tp++] = t;//第一个元素进队列
    vis[x][y] = 1;//标记第一个元素
    while(tl < tp)
    {
        t = ls[tl++];
        if(mp[t.x][t.y] == 'X' && !vis[t.x][t.y])//如果某个X未被访问过
        {
            dfs(t.x,t.y);//开始遍历
            num++;//每调用一次dfs,就是发现了一个或是一群X
        }
        for(i = 0; i < 4; i++)
        {
            f.x = t.x + bhx[i];
            f.y = t.y + bhy[i];
            if(f.x >= 0 &&f.x < n &&f.y >= 0 && f.y < m && !vis[f.x][f.y] && mp[f.x][f.y] != '.')//在*群里搜索,找X
            {
                ls[tp++] = f;
                if(mp[f.x][f.y] != 'X')//是X的话就不标记,X在dfs标记
                vis[f.x][f.y] = 1;
            }
        }
    }
    if(num != 0)//如果num是0的话,说明没发现*群里有X,就不统计
    {
        s[js++] = num;
        num = 0;
    }

}

int main()
{
    int i,j;
    int c = 0;
    while(scanf("%d%d",&m,&n),n||m)
    {
        c++;
        js = 0;
        memset(vis,0,sizeof(vis));//vis标记清空
        for(i = 0; i < n; i++)
        {
            scanf("%*c%s",mp[i]);
        }//把地图读入
        for(i = 0; i < n; i++)
        {
            for(j = 0; j <m; j++)
            {
                if((mp[i][j] == '*'|| mp[i][j] == 'X') && !vis[i][j])//循环访问地图,合适的进行bfs搜索
                {
                    bfs(i,j);
                }
            }
        }
        sort(s,s+js);
        printf("Throw %d\n",c);
        for(i = 0; i < js; i++)
        {
            printf("%d",s[i]);
            if(i < js - 1)
                printf(" ");
        }
        printf("\n\n");
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值