pat advanced 1046

22 篇文章 0 订阅
地址:http://pat.zju.edu.cn/contests/pat-a-practise/1046


1046. Shortest Distance (20)


时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.


Input Specification:


Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.


Output Specification:


For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.


Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10

7


思路:求一个环里的任意两点的最短路径,环上要么顺时针走,要么逆时针走,输入的时候可以记下所有节点的和sum,走一遍算路径长度 x 即可,比较 x 和 sum - x 的大小。

但是对每个pair对,从起点到终点求和最后一个case 会超时。

参考了linest大神的思路:

A到B的距离(A<B) = 1~B距离 - 1~A距离(http://linest.github.io/blog/2013/05/29/pat_1046/)

fibonacci的参考代码:

代码中arr[N] 即上面分析中的sum。

#include<cstdio>
int arr[100001];

int main()
{
    int N, M, num, a, b;
    scanf("%d", &N);
    for(int i = 1; i<=N; ++i)
    {
        scanf("%d", &num);
        arr[i] = arr[i-1] + num;
    }
    scanf("%d", &M);
    for(int i = 0; i < M; ++i)
    {
        scanf("%d %d", &a, &b);
        if(a > b)
        {
            a = a^b;
            b = a^b;
            a = a^b;
        }
        if(arr[b-1]-arr[a-1] < arr[N] - arr[b-1] + arr[a-1])
        {
            printf("%d\n", arr[b-1]-arr[a-1]);
        }
        else
        {
            printf("%d\n", arr[N]-arr[b-1]+arr[a-1]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值