2022-05-24每日刷题打卡

2022-05-24每日刷题打卡

代码源——每日一题

一半相等 - 题目 - Daimayuan Online Judge

给定 n (n 为偶数)个整数数组 a1,a2,…,an
考虑这样的一个 k,每次操作选定一个 i,将 ai 减少 k,执行多次(可能 0 次)后使得数组中至少有一半的元素相等,求最大的 k,如果这样的 k 为无穷大,输出 −1

输入格式

输入包含两行,第一行为一个正整数 n,表示数组大小。第二行为 n 个整数 a1,a2,…,an

输出格式

输出题意中的 k

样例输入

8
-1 0 1 -1 0 1 -1 0

样例输出

2

数据规模

4≤n≤100,数据保证 n 为偶数

−10 ^ 6≤ai≤10 ^ 6

首先可以知道,如果数组中已经有一半的数相等了,那么不管k取多大,都可以确保有一半的数组相等,直接输出-1。

如果没有一半的数相等,我们就计算出数组中两两数的差值,然后求出所有差值的因子,只要这个因子能够使得数组中有一半的数相等,我们就记录下来,在此过程中维护最大值。

#include<iostream>
using namespace std;
#include<vector>
#include<algorithm>
#include<math.h>
#include<set>
#include<numeric>
#include<string>
#include<string.h>
#include<iterator>
#include<fstream>
#include<map>
#include<unordered_map>
#include<stack>
#include<list>
#include<queue>
#include<iomanip>

set<int> divide(int x)
{
    set<int> q;
    for (int i = 1; i * i <= x; i++)
    {
        if (x % i == 0)
        {
            q.insert(i);
            q.insert(x / i);
        }
    }
    return q;
}
int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);
    cout.tie(0);
    int n;
    cin >> n;
    vector<int> a(n);
    for (int i = 0; i < n; i++)
    {
        cin >> a[i];
    }
    int k = -1;
    for (int i = 0; i < a.size(); i++)
    {
        int minv = a[i];
        int same = 0;
        vector<int> d;
        for (int j = 0; j < a.size(); j++)
        {
            if (a[j] == minv)
                same++;
            else if (a[j] > minv)
            {
                d.push_back(a[j] - minv);
            }
        }
        if (same >= n / 2)
        {
            cout << -1 << endl;
            return 0;
        }
        map<int, int> mp;
        for (auto x : d)
        {
            for (auto xx : divide(x))
            {
                mp[xx]++;
            }
        }
        for (auto x : mp)
        {
            if (x.second + same >= n / 2)
            {
                k = max(k, x.first);
            }
        }
    }
    cout << k << endl;

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值