[PAT]1004. 成绩排名 (20)

读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:每个测试输入包含1个测试用例,格式为

  第1行:正整数n

  第2行:第1个学生的姓名 学号 成绩

  第3行:第2个学生的姓名 学号 成绩

  ... ... ...

  第n+1行:第n个学生的姓名 学号 成绩

其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。


输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

输入样例:

3

Joe Math990112 89

Mike CS991301 100

Mary EE990830 95

输出样例:

Mike CS991301

Joe Math990112

方法一:通过map关联容器

//通过关联容器map完成
#include <iostream>
#include <map>
#include <string>
using namespace std;
class CStudent{
public:
	struct CInfo{
		string id;
		string name;
	};
	int score;
	CInfo info;
};
//声明关联容器map
typedef map<int,CStudent::CInfo> MAP_STD;
int main(){
	MAP_STD mp;
	CStudent st;
	int n;
	while(cin>>n){
		for(int i=0;i<n;i++){
			cin>>st.info.name>>st.info.id>>st.score;
			mp.insert(make_pair(st.score,st.info));
		}
		MAP_STD::iterator p=mp.end();
		--p;
		cout<<p->second.name<<" "<<p->second.id<<endl;
		p=mp.begin();
		cout<<p->second.name<<" "<<p->second.id<<endl;

	}
}
方法二:通过sort函数

#include "stdio.h"
#include "algorithm"
using namespace std;
typedef struct CStudent{
	char name[11];
	char id[11];
	int score;
}Student;
//自定义比较函数
int Cmp(Student pa,Student pb){
	return pa.score<pb.score;
}
int main(){
	Student st[1000];
	int n;
	while(scanf("%d",&n)!=EOF){
		for(int i=0;i<n;i++){
			scanf("%s",st[i].name);
			scanf("%s",st[i].id);
			scanf("%d",&st[i].score);


		}
		sort(st,st+n,Cmp);
		printf("%s %s\n",st[n-1].name,st[n-1].id);
		printf("%s %s\n",st[0].name,st[0].id);

	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值