Find a way HDU 2612

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input

The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input

4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#

Sample Output

66
88
66
#include <iostream>
#include<bits/stdc++.h>
#define inf 0x3f3f3f3f
using namespace std;
char maze[202][202];
int m,n;
typedef pair<int,int> p;
p people[2];  //两个好朋友
p a[4005];    //记录@位置,(其实没必要)
bool book[202][202];    
int ax[4][2]={-1,0,0,1,1,0,0,-1};//方向
int kfs=-1;   
int ans;
int ti[2][202][202];//记录两个好朋友,走到9月9,遍地大江南北在不同的地方所花的不同的时间
void bfs(int f)
{
    memset(book,false,sizeof(book));
    queue<p>q;
    q.push(people[f]);
    book[people[f].first][people[f].second]=true;
    ti[f][people[f].first][people[f].second]=0;
    while(!q.empty())
    {
        p now;
        now=q.front();
        q.pop();
        for(int i=0;i<4; i++)
        {
            int nx,ny;
            nx=now.first+ax[i][0];
            ny=now.second+ax[i][1];
            if(nx>=1&&nx<=n&&ny>=1&&ny<=m&&!book[nx][ny]&&maze[nx][ny]!='#')
            {
                ti[f][nx][ny]=ti[f][now.first][now.second]+11;
                book[nx][ny]=true;
                q.push(p(nx,ny));
            }
        }
    }
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        ans=inf;
        kfs=-1;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                cin>>maze[i][j];
                if(maze[i][j]=='Y')
                    people[0].first=i,people[0].second=j;
                if(maze[i][j]=='M')
                    people[1].first=i,people[1].second=j;
                if(maze[i][j]=='@')
                {
                    a[++kfs].first=i,a[kfs].second=j;
                    //cout<<a[kfs].first<<' '<<a[kfs].second<<endl;
                }
                ti[0][i][j]=inf;
                ti[1][i][j]=inf;
            }
        }
        bfs(0);
        bfs(1);
        for(int i=0;i<=kfs;i++)  //取最小
        {
            ans=min(ans,ti[0][a[i].first][a[i].second]+ti[1][a[i].first][a[i].second]);
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值