nyoj-1112-求次数

求次数

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述

题意很简单,给一个数n 以及一个字符串str,区间【i,i+n-1】 为一个新的字符串,i 属于【0,strlen(str)】如果新的字符串出现过ans++,例如:acmacm n=3,那么 子串为acm cma mac acm ,只有acm出现过

求ans;

输入
LINE 1: T组数据(T<10)
LINE 2: n ,n <= 10,且小于strlen(str);
LINE 3:str
str 仅包含英文小写字母 ,切长度小于10w
输出
求 ans
样例输入
2
2
aaaaaaa
3
acmacm
样例输出
5
1
上传者

ACM_王亚龙


这题 的题目  唉!开始做的误解题意了一直都不过,,最后看了别人发博客才知道我把题意理解错了,,题意大概是,把字符串 截成长度为n的小串然后找小串重复的。第一个代码用stl  的map做的,,发现用时好多然后又改成  string了。

#include<string>
#include<iostream>
#include<map>
using namespace std;
int main()
{
    int T,n;
    cin>>T;
    while(T--)
    {
        string str,s1;
        int sign;
        cin>>n>>str;
        map<string,bool>snum;
        int ans=0;
        int l=str.size()-n+1;
        for(int i=0;i<l;i++){
            s1=str.substr(i,n);
            if(snum[s1]==1) ans++;
            else snum[s1]=1;
        }
        cout<<ans<<endl;
    }
    return 0;
}

下面这个耗时间比较短。

#include<string>
#include<algorithm>
#include<cstdio>
#include<iostream>
using namespace std;
string ss[110000];
int main()
{
    int T,n;
    string str;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        cin>>str;
        int count=0;
        for(int i=0;i<str.size()-n+1;i++)
        {
            ss[count++]=str.substr(i,n);
        }
        int ans=0;
        string t;
        sort(ss,ss+count);
        for(int i=0;i<count;i++)
        {
            t=ss[i];
            for(int j=i+1;j<count;j++)
            {
                if(t==ss[j])
                {
                    ans++;
                    i=j;
                }
                else break;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值