hdu-多校训练赛-KazaQ's Socks

KazaQ's Socks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
KazaQ wears socks everyday.

At the beginning, he has  n  pairs of socks numbered from  1  to  n  in his closets. 

Every morning, he puts on a pair of socks which has the smallest number in the closets. 

Every evening, he puts this pair of socks in the basket. If there are  n1  pairs of socks in the basket now, lazy  KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the  k -th day.
 

Input
The input consists of multiple test cases. (about  2000 )

For each case, there is a line contains two numbers  n,k   (2n109,1k1018) .
 

Output
For each test case, output " Case # x y " in one line (without quotes), where  x  indicates the case number starting from  1  and  y  denotes the answer of corresponding case.
 

Sample Input
   
   
3 7 3 6 4 9
 

Sample Output
   
   
Case #1: 3 Case #2: 1 Case #3: 2

题意:
KazaQ 柜子里放着n双袜子,标号分别从1到n,KazaQ 每天早上都会从柜子里拿一双编号最小的袜子穿,夜晚把白天穿的袜子放到一个篮子里,等篮子里的袜子积攒到n-1双后,他就不得不洗,等第二天夜晚把洗完的袜子放到柜子里,给出n和k,求第k天KazaQ 穿的袜子编号是多少。
分析:是一道规律题。如果k小于n,那么第k天的袜子标号一定是k;如果k大于n,从第n天开始,只有编号最大的和次大的有变动
一个简单的规律;;  Case:3    1 2 3 4, 1 2 3, 1 2 4, 1 2 3, 1 2 4......
 

#include<cstdio>
using namespace std;
int main()
{
   long long int n,k;
    int t=0;
    while(~scanf("%lld %lld",&n,&k)){
        t++;
        printf("Case #%d: ",t);
        if(k<n) printf("%lld\n",k);
        else{
            if((k-n)%(n-1)==0){
                if((k-n)/(n-1)%2==0) printf("%lld\n",n);
                else
                    printf("%lld\n",n-1);
            }
            else
                printf("%d\n",(k-n)%(n-1));
        }
    }
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值