hdu 1715 大菲波数(java)

Problem Description
Fibonacci数列,定义如下:
f(1)=f(2)=1
f(n)=f(n-1)+f(n-2) n>=3。
计算第n项Fibonacci数值。
 

Input
输入第一行为一个整数N,接下来N行为整数Pi(1<=Pi<=1000)。
 

Output
输出为N行,每行为对应的f(Pi)。
 

Sample Input
  
  
5 1 2 3 4 5
 

Sample Output
  
  
1 1 2 3 5
 
大数,,懒直接java写
code:
import java.math.BigInteger;
import java.util.Scanner;
public class Main {

    public static void main(String[] args) {
        Scanner cin =new Scanner(System.in);
        int t=cin.nextInt();
        while(t--!=0){
            int n = cin.nextInt();
            System.out.println(fic(n));
        }
    }
    private static BigInteger fic(int n) {
        BigInteger f =new BigInteger("1");
        BigInteger d =new BigInteger("2"); 
        if(n==1||n==2) return f;
        else if(n==3)return d;
        int sum =3;
        while(true) {
            sum++;
            BigInteger tem =f;
            f=d;
            d=f.add(tem);
            //d=tem;
            if(sum==n) return d;
        }
        //return d;
    }

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值