POJ-1028-Web Navigation


Web Navigation 
Problem Description
Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this. 
The following commands need to be supported: 
BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored. 
FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored. 
VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied. 
QUIT: Quit the browser. 
Assume that the browser initially loads the web page at the URL http://www.acm.org/
 

Input
Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.
 

Output
For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.
 

Sample Input
  
  
VISIT http://acm.ashland.edu/ VISIT http://acm.baylor.edu/acmicpc/ BACK BACK BACK FORWARD VISIT http://www.ibm.com/ BACK BACK FORWARD FORWARD FORWARD QUIT
 

Sample Output
  
  
http://acm.ashland.edu/ http://acm.baylor.edu/acmicpc/ http://acm.ashland.edu/ http://www.acm.org/ Ignored http://acm.ashland.edu/ http://www.ibm.com/ http://acm.ashland.edu/ http://www.acm.org/ http://acm.ashland.edu/ http://www.ibm.com/ Ignored
 

题意简述:
  这题是一个模拟WEB浏览器的程序,默认主页为http://www.acm.org/输入为指令,出书为当前页面的网址。
输入的指令有4种:
  (1)VISIT(后接一个网址)——访问它后面紧接着的网址。
  (2)BACK——访问当前网页的前一个。
  (3)FORWARD——访问当前网页的后一个。
  (4)QUIT——退出(关闭浏览器)。
注意:的是如果新加网页的话,后面的网页全部没有了。
用链表模拟。。。
code:
#include<iostream>
#include<string>
using namespace std;
struct node
{
    string s;
    node *e,*f;
    node()
    {
        e=f=NULL;
    }
};
int main()
{
    string str1,str2;
    node *p,*l,*q;
    l=new node;
    p=l;
    l->s="http://www.acm.org/";
    while(cin>>str1)
    {
        if(str1=="QUIT") break;
        if(str1=="VISIT"){
            cin>>str2;
            q=new node;
            q->s=str2;
            //if(p->e==NULL){
                q->f=p;p->e=q;
                p=q;
                cout<<str2<<endl;
            /*}else {
                p->e->f=q;
                q->f=p;q->e=p->e;
                p->e=q;
                p=q;
                cout<<str2<<endl;
            }*/
        }else if(str1=="BACK"){
            if(p->f==NULL){
                cout<<"Ignored"<<endl;
            }else {
                p=p->f;
                cout<<(p->s)<<endl;
            }
        }else if(str1=="FORWARD"){
            if(p->e==NULL)
                cout<<"Ignored"<<endl;
            else {
                p=p->e;
                cout<<(p->s)<<endl;
            }
        }
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值