Knights

Knights

Time Limit:50000MS Memory Limit:65536K
Total Submit:126 Accepted:31
Case Time Limit:10000MS

Description

  We are given a chess-board of size n*n, from which some fields have been removed. The task is to determine the maximum number of knights that can be placed on the remaining fields of the board in such a way that none of them check each other.
  一张大小为n*n的国际象棋棋盘,上面有一些格子被拿走了,棋盘规模n不超过200。马的攻击方向如下图,其中S处为马位置,标有X的点为该马的攻击点。

Fig.1: A knight placed on the field S checks fields marked with x.
Write a program, that:
reads the description of a chess-board with some fields removed, from the input file kni.in,
determines the maximum number of knights that can be placed on the chess-board in such a way that none of them check each other,
writes the result to the output file kni.out.
你的任务是确定在这个棋盘上放置尽可能多的马,并使他们不互相攻击。

Input

The first line of the input file kni.in contains two integers n and m, separated by a single space, 1<=n<=200, 0<=m<n2; n is the chess-board size and m is the number of removed fields. Each of the following m lines contains two integers: x and y, separated by a single space, 1<=x,y<=n – these are the coordinates of the removed fields. The coordinates of the upper left corner of the board are (1,1), and of the bottom right are (n,n). The removed fields are not repeated in the file.

Output

The output file kni.out should contain one integer (in the first and only line of the file). It should be the maximum number of knights that can be placed on the given chess-board without checking each other.

Sample Input

3 2

1 1

3 3

Sample Output

5
做法:求最大匹配。。这里是用邻接矩阵,比较慢

#include <cstdio>
#include <iostream>
#include <cmath>
using namespace std;
const int dx[9]={0,1,2,2,1,-1,-2,-2,-1};
const int dy[9]={0,2,1,-1,-2,-2,-1,1,2};
int n,m;
bool map[300][300],v[50000];
int num[300][300],f[50000][9],link[50000];

bool check(int a,int b)
{
    if (a<1||a>n||b<1||b>n) return false;
    if (map[a][b])  return false;
    return true;
}

bool find(int x)
{
    int k;
    for (int i=1;i<=f[x][0];i++)
        if (v[f[x][i]]!=1)
        {
            k=link[f[x][i]];    link[f[x][i]]=x;    v[f[x][i]]=1;
            if (k==0||find(k))  return true;
            link[f[x][i]]=k;
        }
    return false;
}

int main()
{
    cin>>n>>m;
    for (int i=1;i<=m;i++)
    {
        int x,y;
        cin>>x>>y;
        map[x][y]=true;
    }
    int s=0;
    for (int i=1;i<=n;i++)
        for (int j=1;j<=n;j++)
            if (map[i][j]!=1)
            {
                s++;
                num[i][j]=s;
            }
    for (int i=1;i<=n;i++)
        for (int j=1;j<=n;j++)
            if (map[i][j]==0)
            {
                int p,t,x,y;
                p=num[i][j];
                t=0;
                for (int k=1;k<=8;k++)
                {
                    x=i+dx[k];
                    y=j+dy[k];
                    if (check(x,y))
                    {
                        t++;
                        f[p][t]=num[x][y];
                    }
                }
                f[p][0]=t;  
            }
    int ans=0;
    for (int i=1;i<=s;i++)
    {
        if (f[i][0]==0) continue;
        memset(v,0,sizeof(v));
        if  (find(i))   ans++;  
    }
    ans=ans/2;
    cout<<s-ans;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值