原来这个叫做广搜啊。。。

题目来源  poj3278 ;

 Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastes  way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


这个题目的思想还是挺简单,也不要求剪枝优化什么的,所以根据题意直接写,另外,通过这个题目学了一些stl <queue>库函数的一些用法。。


代码:

#include <iostream>
#include <queue>
#include <cstdio>
#include <cstring>
using namespace std;

int main()
{
	int line[100001]={0};
	bool sign[100001]={0};
	queue<int>x;        // 创建一个int型的队列。。
	int n,k;
	cin>>n>>k;
    	x.push(n);       // 将n压入队列x队首。
    	line[n]=0;       
	    while(!x.empty())
		{
		  int y=x.front()  ;     //将x的队头赋值给y。;
		  x.pop();              //上一步没有将队头取出,这一步取出队头。
		  sign[n]=true;         //初始位置设为走过。
		  if(y==k) break;        
		  else 
		  {
			if(y>=1&&!sign[y-1])
			 {
				x.push(y-1);             //将y-1压入x队首。
				line[y-1]=line[y]+1;
				sign[y-1]=true;
			 }
			if(y+1<=100000&&!sign[y+1])
			  {
				x.push(y+1);
				line[y+1]=line[y]+1;
				sign[y+1]=true;
			  }
			if(y<=50000&&!sign[y*2])
			  {
				x.push(y*2);
				line[y*2]=line[y]+1;
				sign[y*2]=true;
			  }
		  }
		}
		printf("%d\n",line[k]);

	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值