题目的意思是在一个网格中有若干个点,每一次可以一下子清除一行或者一列,问多少次可以将网格中的点全部清除。
分析:将行做表看作一个集合的点,列坐标看作一个集合的点,每个点就连接两个集合的边,求出最大匹配就是所要的答案。。。
题目:
Asteroids
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 7887 | Accepted: 4196 |
Description
Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.
Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input
* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output
* Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input
3 4 1 1 1 3 2 2 3 2
Sample Output
2
Hint
INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.
OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.
OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
匈牙利算法,代码:
#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
int map[505][505];
int vis[1001];
int flag[1001]; //flag[i]记录与i相连的边。
int n,m;
bool dfs(int s) //一般也写作find(int s)
{
int i,j;
for(i=1;i<=n;i++)
{
if(!vis[i] && map[s][i])
{
vis[i]=1;
if(flag[i]==0 || dfs(flag[i])) //若i没有于别的边相连,或者与i相连的那条边于变得边相连。
{
flag[i]=s;
return true;
}
}
}
return false;
}
int main()
{
int k,x,y,i,j;
while(scanf("%d%d",&n,&k)!=EOF)
{
memset(map,0,sizeof(map));
memset(flag,0,sizeof(flag));
for(i=0;i<k;i++)
{
scanf("%d%d",&x,&y);
map[x][y]=1;
}
int result=0;
for(i=1;i<=n;i++)
{
memset(vis,0,sizeof(vis));
if(dfs(i)) result++;
}
cout<<result<<endl;
}
return 0;
}