poj 1844 数学问题

Sum
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 9591 Accepted: 6281

Description

Consider the natural numbers from 1 to N. By associating to each number a sign (+ or -) and calculating the value of this expression we obtain a sum S. The problem is to determine for a given sum S the minimum number N for which we can obtain S by associating signs for all numbers between 1 to N.

For a given S, find out the minimum value N in order to obtain S according to the conditions of the problem.

Input

The only line contains in the first line a positive integer S (0< S <= 100000) which represents the sum to be obtained.

Output

The output will contain the minimum number N for which the sum S can be obtained.

Sample Input

12

Sample Output

7

Hint

The sum 12 can be obtained from at least 7 terms in the following way: 12 = -1+2+3+4+5+6-7.

Source

 
本题可以理解为数学问题,我们首先不尝试减号的情况,设输入数据为s 如果s可以恰巧等于1……n这n个数累加的和sum ,我们可以直接输出n
否则,sum一定会大于s,此时,如果(sum-s)为偶数,我们就可以在1……n这n个数中找到两个和为(sum-s)/2 的数字 ,把他们改成减号,就相当于在sum中减去了(sum-s),问题解决.
 
#include<iostream>
using namespace std;
int main()
{
	int sum=0,s,n=0;
	cin>>s;
	while(sum<s||(sum-s)%2==1){
		n++;
		sum+=n;
	}
	cout<<n;
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值