POJ 1844 Sum(数学)

题目链接:Click me!

                                                         Sum

Consider the natural numbers from 1 to N. By associating to each number a sign (+ or -) and calculating the value of this expression we obtain a sum S. The problem is to determine for a given sum S the minimum number N for which we can obtain S by associating signs for all numbers between 1 to N.Description


For a given S, find out the minimum value N in order to obtain S according to the conditions of the problem.

Input

The only line contains in the first line a positive integer S (0< S <= 100000) which represents the sum to be obtained.

Output

The output will contain the minimum number N for which the sum S can be obtained.

Sample Input

12

Sample Output

7

Hint

The sum 12 can be obtained from at least 7 terms in the following way: 12 = -1+2+3+4+5+6-7.

题意解析:

这道题呢,意思就是,给出一个S,你需要去寻找到一个最小的N,然后需要得出从1~N的和(可正可负)为S,输出这个N即可,比如12 = -1 + 2 + 3 + 4 + 5 + 6 - 7,那么结果就是7

其实就两行代码,第一需要知道,最小的N,也就是在同样能得到S的情况下,符号绝大多数为正的话,才能尽可能得到最小的N,比如12 = -1 + 2 + 3 + 4 + 5 + 6 - 712 =  -1 + 2 + 3 - 4 + 5 + 6 - 7 + 8,故我们先令1~N中全为正,然后求和,如果当前的前N项和大于S,且(SUM-S)% 2 = 0,那么久可以得到这个S,而且得到的N是最小的N

代码篇:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
int main()
{
    int sum, i, j, k;
    scanf("%d",&k);
    sum = 0;
    i = 1;
    while(1)
    {
        sum += i++;
        if(sum >= k && (sum - k) % 2 == 0)
        {
            printf("%d\n",i - 1);
            return 0;
        }
    }
    return 0;
}

 

OVER!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值