Anagram
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 16165 | Accepted: 6589 |
Description
You are to write a program that has to generate all possible words from a given set of letters.
Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba".
In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.
Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba".
In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.
Input
The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different. The length of each word is less than 13.
Output
For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter.
Sample Input
3 aAb abc acba
Sample Output
Aab Aba aAb abA bAa baA abc acb bac bca cab cba aabc aacb abac abca acab acba baac baca bcaa caab caba cbaa
Hint
An upper case letter goes before the corresponding lower case letter.
So the right order of letters is 'A'<'a'<'B'<'b'<...<'Z'<'z'.
So the right order of letters is 'A'<'a'<'B'<'b'<...<'Z'<'z'.
Source
本题重点在cmp函数的定义上~
#include<iostream>
#include<algorithm>
#include<stdlib.h>
using namespace std;
bool cmp(const char &a, const char &b)
{
if(a<='Z' && a>='A' && b<='Z' && b>='A')
return a<b;
if(a<='z' && a>='a' && b<='z' && b>='a')
return a<b;
if(a<='Z' && a>='A' && b<='z' && b>='a')
return a+'a'-'A'<=b;
if(a<='z' && a>='a' && b<='Z' && b>='A')
return a<b+'a'-'A';
}
int main(){
// freopen("C:/Users/Administrator/Desktop/contest95/Anagram/anagram.in","r",stdin);
// freopen("C:/Users/Administrator/Desktop/contest95/Anagram/anagram11.txt","w",stdout);
int n;
char str[1000];
scanf("%d",&n);
while(n--){
scanf("%s",&str);
int len = strlen(str);
sort(str,str+len,cmp);
printf("%s\n",str);
while(next_permutation(str,str+len,cmp)){
printf("%s\n",str);
}
}
return 0;
}