链表的逆置

Problem Description
输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。
Input
输入多个整数,以-1作为结束标志。
Output
输出逆置后的单链表数据。
Example Input
12 56 4 6 55 15 33 62 -1
Example Output
62 33 15 55 6 4 56 12
Author
 
#include <bits/stdc++.h>

using namespace std;

struct node
{
    int data;
    struct node *next;
};

struct node *CreatList(int n)
{
    struct node *head,*tail,*p,*q;
    int i;

    head = (struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;

    while(1)
    {
        p=(struct node *)malloc(sizeof(struct node));
        cin>>p->data;
        if(p->data==-1)
            break;
        p->next=NULL;
        tail->next=p;
        tail=p;
    }

    p=head->next;
    q=p->next;
    head->next=NULL;
    while(p)
    {
        p->next=head->next;
        head->next=p;
        p=q;
        if(q)
            q=q->next;
    }
    return (head);
};

int main()
{
    struct node *head,*r;
    int i,j,k,m,n;

    head=CreatList(n);

    r=head->next;

    while(r)
    {
        if(r->next==NULL)
            cout<<r->data<<endl;
        else
            cout<<r->data<<" ";
        r=r->next;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值