hdu2795Billboard

题目描述:
Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.

Sample Input
3 5 5
2
4
3
3
3

Sample Output
1
2
1
3
-1

题意 :
给出几组测试样例,每组样例给出h,w,n,指有一块h*w的矩形广告板,要往上面贴广告; 然后给n个1*wi的广告,要求把广告贴上去;
而且要求广告要尽量往上贴并且尽量靠左; 输出每个广告的所在的位置,不能贴则输出-1;

题解:用线段树记录区间最大值,查询时比较区间最大值与海报宽度即可确定能否继续往下搜寻,此处没必要开1e9的数组,因为1 <= n <= 200000,取h和n的最小值即可。

ac代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=2e5+5;
int a[maxn*4];
int h,w,n,p;
void build(int o,int l,int r);
int query(int o,int l,int r);
int main()
{
    while(~scanf("%d%d%d",&h,&w,&n))
    {
        int f=min(h,n);
        build(1,1,f);
        while(n--)
        {
            scanf("%d",&p);
            if(p>a[1])
            printf("-1\n");
            else
            {
                int  ans=query(1,1,f);
                printf("%d\n",ans);
            }
        }
    }

}

void build(int o,int l,int r)
{
    a[o]=w;
    if(l==r)
    return;
    int m=l+(r-l)/2;
    build(o*2,l,m);
    build(o*2+1,m+1,r);
}

int query(int o,int l,int r)
{
    int ans;
    int m=l+(r-l)/2;
    if(l==r)
    {
        a[o]-=p;
        return l;
    }
    if(a[o*2]>=p)
    ans=query(o*2,l,m);
    else
    ans=query(o*2+1,m+1,r);
    a[o]=max(a[o*2],a[o*2+1]);
    return ans;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值