poj 1151 Atlantis(线段树 扫描线)

 

 

Atlantis
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8759 Accepted: 3457

Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input

The input consists of several test cases. Each test case starts with a line containing a single integer n (1 <= n <= 100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0 <= x1 < x2 <= 100000;0 <= y1 < y2 <= 100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area. 
The input file is terminated by a line containing a single 0. Don't process it.

Output

For each test case, your program should output one section. The first line of each section must be "Test case #k", where k is the number of the test case (starting with 1). The second one must be "Total explored area: a", where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point. 
Output a blank line after each test case.

Sample Input

2
10 10 20 20
15 15 25 25.5
0

Sample Output

Test case #1
Total explored area: 180.00 

Source

 

分析:此题与1177类似,这回试着以节点来构造线段树,这样速度较快,而且就适用于带小数的线段了

更新了下代码

#include<cstdio>
#include<iostream>
#include<algorithm>
#define ls rt<<1
#define rs rt<<1|1
#define lson l,m,ls
#define rson m,r,rs
using namespace std;
const int mm=222;
const int mn=mm<<2;
struct seg
{
    double x,y1,y2;
    int v;
}g[mm];
double y[mm],sum[mn],L,R;
int t[mn],val;
void build()
{
    for(int i=0;i<mn;++i)sum[i]=t[i]=0;
}
void updata(int l,int r,int rt)
{
    if(l>=r)return;
    if(L<=y[l]&&R>=y[r])t[rt]+=val;
    else
    {
        int m=(l+r)>>1;
        if(L<y[m])updata(lson);
        if(R>y[m])updata(rson);
    }
    if(t[rt])sum[rt]=y[r]-y[l];
    else if(l==r)sum[rt]=0;
    else sum[rt]=sum[ls]+sum[rs];
}
bool cmp(seg a,seg b)
{
    return a.x<b.x;
}
int main()
{
    int i,j,n,m,cs=0;
    double ans;
    while(scanf("%d",&n),n)
    {
        for(j=i=0;i<n;++i,j+=2)
        {
            scanf("%lf%lf%lf%lf",&g[j].x,&y[j],&g[j+1].x,&y[j+1]);
            g[j].y1=g[j+1].y1=y[j];
            g[j].y2=g[j+1].y2=y[j+1];
            g[j].v=1,g[j+1].v=-1;
        }
        sort(y,y+j);
        sort(g,g+j,cmp);
        for(m=i=0;i<j;++i)
            if(y[m]<y[i])y[++m]=y[i];
        build();
        for(ans=i=0;i<j;++i)
        {
            L=g[i].y1,R=g[i].y2,val=g[i].v;
            updata(0,m,1);
            if(g[i].x<g[i+1].x)ans+=(g[i+1].x-g[i].x)*sum[1];
        }
        printf("Test case #%d\nTotal explored area: %.2lf\n\n",++cs,ans);
    }
    return 0;
}


贴下代码:

 

此题数据较小,也可不用线段树(好像~~~):

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值