POJ 2482 Stars in Your Window(线段树扫描线)

http://poj.org/problem?id=2482

Stars in Your Window
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9909 Accepted: 2743

Description

Fleeting time does not blur my memory of you. Can it really be 4 years since I first saw you? I still remember, vividly, on the beautiful Zhuhai Campus, 4 years ago, from the moment I saw you smile, as you were walking out of the classroom and turned your head back, with the soft sunset glow shining on your rosy cheek, I knew, I knew that I was already drunk on you. Then, after several months’ observation and prying, your grace and your wisdom, your attitude to life and your aspiration for future were all strongly impressed on my memory. You were the glamorous and sunny girl whom I always dream of to share the rest of my life with. Alas, actually you were far beyond my wildest dreams and I had no idea about how to bridge that gulf between you and me. So I schemed nothing but to wait, to wait for an appropriate opportunity. Till now — the arrival of graduation, I realize I am such an idiot that one should create the opportunity and seize it instead of just waiting. 

These days, having parted with friends, roommates and classmates one after another, I still cannot believe the fact that after waving hands, these familiar faces will soon vanish from our life and become no more than a memory. I will move out from school tomorrow. And you are planning to fly far far away, to pursue your future and fulfill your dreams. Perhaps we will not meet each other any more if without fate and luck. So tonight, I was wandering around your dormitory building hoping to meet you there by chance. But contradictorily, your appearance must quicken my heartbeat and my clumsy tongue might be not able to belch out a word. I cannot remember how many times I have passed your dormitory building both in Zhuhai and Guangzhou, and each time aspired to see you appear in the balcony or your silhouette that cast on the window. I cannot remember how many times this idea comes to my mind: call her out to have dinner or at least a conversation. But each time, thinking of your excellence and my commonness, the predominance of timidity over courage drove me leave silently. 

Graduation, means the end of life in university, the end of these glorious, romantic years. Your lovely smile which is my original incentive to work hard and this unrequited love will be both sealed as a memory in the deep of my heart and my mind. Graduation, also means a start of new life, a footprint on the way to bright prospect. I truly hope you will be happy everyday abroad and everything goes well. Meanwhile, I will try to get out from puerility and become more sophisticated. To pursue my own love and happiness here in reality will be my ideal I never desert. 

Farewell, my princess! 

If someday, somewhere, we have a chance to gather, even as gray-haired man and woman, at that time, I hope we can be good friends to share this memory proudly to relight the youthful and joyful emotions. If this chance never comes, I wish I were the stars in the sky and twinkling in your window, to bless you far away, as friends, to accompany you every night, sharing the sweet dreams or going through the nightmares together. 

Here comes the problem: Assume the sky is a flat plane. All the stars lie on it with a location (x, y). for each star, there is a grade ranging from 1 to 100, representing its brightness, where 100 is the brightest and 1 is the weakest. The window is a rectangle whose edges are parallel to the x-axis or y-axis. Your task is to tell where I should put the window in order to maximize the sum of the brightness of the stars within the window. Note, the stars which are right on the edge of the window does not count. The window can be translated but rotation is not allowed. 

Input

There are several test cases in the input. The first line of each case contains 3 integers: n, W, H, indicating the number of stars, the horizontal length and the vertical height of the rectangle-shaped window. Then n lines follow, with 3 integers each: x, y, c, telling the location (x, y) and the brightness of each star. No two stars are on the same point. 

There are at least 1 and at most 10000 stars in the sky. 1<=W,H<=1000000, 0<=x,y<2^31. 

Output

For each test case, output the maximum brightness in a single line.

Sample Input

3 5 4
1 2 3
2 3 2
6 3 1
3 5 4
1 2 3
2 3 2
5 3 1

Sample Output

5
6

Source

POJ Contest,Author:kinfkong@ZSU


题意:

背景真是令人感动,我都看得哭了......

前面的自己看吧。

给出星星的坐标和亮度,给定一个矩形(长/宽),求框住的星星亮度和的最大值,恰好在边上的不算。

分析:

一个月前在上海邀请赛就有这样的题,当时我线段树只会成段更新,所以那道题目也没碰...

我们这样想,每个星星能影响的范围就是给定矩形的面积,为方便起见,不妨设星星的位置为矩形的左下角。

那么在这个范围内的点全部加上它的亮度,最终我们就是求该平面内的最大值。

这样的话就要用到二维线段树...可是有10k颗星星...这要开多大的数组啊......

那么有没有更优雅的方法呢?

当然有啦!

想一想能否降维,一颗星星影响的范围是有限的,如过降成一维,那么在这棵线段树上我们可以维护x轴的影响(区间加,维护最大值),那么y轴的影响如何控制呢?想一想线段树扫描线求矩形面积并.我们只要在它影响的范围过去过后把这个点的影响去掉就行了。

这样方法就显而易见了:对于每颗星星,我们构造两条边:一条范围[x,x+w),高度为y,权值为brightness,另一条范围[x,x+w),高度为y+h,亮度为-brightness。这样我们对所有边进行排序,从低到高扫描就行了。注意要离散化及边界处理(矩形的边不算,我习惯维护左闭右开的区间所以就不用管了)。


又因为敲错一个变量WA一天多,so ugly!

/*
 *
 *	Author	:	fcbruce
 *
 *	Date	:	2014-08-21 09:19:53 
 *
 */
#include <cstdio>
#include <iostream>
#include <sstream>
#include <cstdlib>
#include <algorithm>
#include <ctime>
#include <cctype>
#include <cmath>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <list>
#include <vector>
#include <map>
#include <set>
#define sqr(x) ((x)*(x))
#define LL long long
#define itn int
#define INF 0x3f3f3f3f
#define PI 3.1415926535897932384626
#define eps 1e-10

#ifdef _WIN32
	#define lld "%I64d"
#else
	#define lld "%lld"
#endif

#define maxm 20007
#define maxn 20007

using namespace std;

struct __edge
{
	long long a,b,y,brightness;
	bool operator < (const __edge &e)const
	{
		if (y==e.y)	return brightness<e.brightness;
		return y<e.y;
	}
}edge[maxm];

long long maxv[maxn<<2],addv[maxn<<2];
long long X[maxn];

inline void pushup(int k)
{
	maxv[k]=max(maxv[k*2+1],maxv[k*2+2]);
}

inline void pushdown(int k)
{
	if (addv[k])
	{
		int lc=k*2+1,rc=k*2+2;
		addv[lc]+=addv[k];addv[rc]+=addv[k];
		maxv[lc]+=addv[k];maxv[rc]+=addv[k];
		addv[k]=0;
	}
}

void update(int a,int b,long long v,int k,int l,int r)
{
	if (b<=l || r<=a)	return ;
	if (a<=l && r<=b)
	{
		addv[k]+=v;
		maxv[k]+=v;
		return ;
	}
	
	pushdown(k);
	update(a,b,v,k*2+1,l,l+r>>1);
	update(a,b,v,k*2+2,l+r>>1,r);
	pushup(k);
}

int main()
{
	#ifndef ONLINE_JUDGE
		freopen("/home/fcbruce/文档/code/t","r",stdin);
	#endif // ONLINE_JUDGE
	
	long long n,w,h;
	
	while (~scanf( lld lld lld,&n,&w,&h))
	{
		memset(maxv,0,sizeof maxv);
		memset(addv,0,sizeof addv);
		LL x,y,brightness;
		for (int i=0;i<n;i++)
		{
			scanf( lld lld lld,&x,&y,&brightness);
			edge[i]=(__edge){x,x+w,y,brightness};
			edge[i+n]=(__edge){x,x+w,y+h,-brightness};
			X[i]=x;
			X[i+n]=x+w;
		}
		
		n<<=1;
		sort(edge,edge+n);
		sort(X,X+n);
		int m=unique(X,X+n)-X;
		
		long long MAX=0;
		for (int i=0;i<n;i++)
		{
			int a=lower_bound(X,X+m,edge[i].a)-X;
			int b=lower_bound(X,X+m,edge[i].b)-X;
			
			update(a,b,edge[i].brightness,0,0,m);
			MAX=max(MAX,maxv[0]);
		}
		
		printf( lld "\n",MAX);
	}
	
	return 0;
}




  • 3
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值