usaco 4.1 Fence Loops(floyd求最小环)

Fence Loops

The fences that surround Farmer Brown's collection of pastures have gotten out of control. They are made up of straight segments from 1 through 200 feet long that join together only at their endpoints though sometimes more than two fences join together at a given endpoint. The result is a web of fences enclosing his pastures. Farmer Brown wants to start to straighten things out. In particular, he wants to know which of the pastures has the smallest perimeter.

Farmer Brown has numbered his fence segments from 1 to N (N = the total number of segments). He knows the following about each fence segment:

  • the length of the segment
  • the segments which connect to it at one end
  • the segments which connect to it at the other end.
Happily, no fence connects to itself.

Given a list of fence segments that represents a set of surrounded pastures, write a program to compute the smallest perimeter of any pasture. As an example, consider a pasture arrangement, with fences numbered 1 to 10 that looks like this one (the numbers are fence ID numbers):

           1
   +---------------+
   |\             /|
  2| \7          / |
   |  \         /  |
   +---+       /   |6
   | 8  \     /10  |
  3|     \9  /     |
   |      \ /      |
   +-------+-------+
       4       5

The pasture with the smallest perimeter is the one that is enclosed by fence segments 2, 7, and 8.

PROGRAM NAME: fence6

INPUT FORMAT

Line 1:N (1 <= N <= 100)
Line 2..3*N+1:

N sets of three line records:

  • The first line of each record contains four integers: s, the segment number (1 <= s <= N); Ls, the length of the segment (1 <= Ls <= 255); N1s (1 <= N1s <= 8) the number of items on the subsequent line; and N2sthe number of items on the line after that (1 <= N2s <= 8).
  • The second line of the record contains N1 integers, each representing a connected line segment on one end of the fence.
  • The third line of the record contains N2 integers, each representing a connected line segment on the other end of the fence.

SAMPLE INPUT (file fence6.in)

10
1 16 2 2
2 7
10 6
2 3 2 2
1 7
8 3
3 3 2 1
8 2
4
4 8 1 3
3
9 10 5
5 8 3 1
9 10 4
6
6 6 1 2 
5 
1 10
7 5 2 2 
1 2
8 9
8 4 2 2
2 3
7 9
9 5 2 3
7 8
4 5 10
10 10 2 3
1 6
4 9 5

OUTPUT FORMAT

The output file should contain a single line with a single integer that represents the shortest surrounded perimeter.

SAMPLE OUTPUT (file fence6.out)

12


题目: http://ace.delos.com/usacoprob2?a=pqqkZ6Lad3C&S=fence6

题意:给你一张图,求其中封闭图形的最小边长,即求图的最小环

分析:求最小环当然想到floyd来做,可是具体怎么实现呢。。。说实在的,我早忘了,自己写了三四遍都错 T_T,百度个模板才A掉,又退化了啊、、、

当然这题的构图比较特殊,我用来个标记两边之间的节点来做,具体看makenode()。。。


代码:

/*
ID: 15114582
PROG: fence6
LANG: C++
*/
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
const int mm=111;
int id[mm][mm],g[mm][mm],d[mm][mm],v[mm];
int i,j,k,n,m,s,len,s1,s2,ans;
int makenode(int n,int u)
{
    int i,now=0;
    for(i=0;i<n;++i)
    {
        scanf("%d",&v[i]);
        if(id[u][v[i]])now=id[u][v[i]];
    }
    if(!now)now=++m;
    for(i=0;i<n;++i)id[u][v[i]]=id[v[i]][u]=now;
    return now;
}
int main()
{
    freopen("fence6.in","r",stdin);
    freopen("fence6.out","w",stdout);
    while(~scanf("%d",&n))
    {
        memset(id,0,sizeof(id));
        memset(d,10,sizeof(d));
        memset(g,10,sizeof(g));
        m=0;
        while(n--)
        {
            scanf("%d%d%d%d",&s,&len,&s1,&s2);
            s1=makenode(s1,s);
            s2=makenode(s2,s);
            g[s1][s2]=g[s2][s1]=d[s1][s2]=d[s2][s1]=len;
        }
        ans=1e9;
        for(k=1;k<=m;++k)
        {
            for(i=1;i<k;++i)
                for(j=i+1;j<k;++j)
                    ans=min(ans,d[i][j]+g[i][k]+g[j][k]);
            for(i=1;i<=m;++i)
                for(j=1;j<=m;++j)
                    d[i][j]=min(d[i][j],d[i][k]+d[k][j]);
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值