poj 2318 TOYS(叉积的应用)

TOYS
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7307 Accepted: 3453

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

Source

题意:给你一些分割好的四边形,统计每个四边形里的点的个数
分析:由于题目的特殊条件,点肯定在格子里了,所以直接用叉积来判断点在线段哪边就行,然后统计,额,这题觉得不好超时就没想优化,枚举水过,不过二分会好一点 ^_^
经过某牛的指点,开始学习并整理计算几何的模板,大家多多指教,以后的模板大概就长下面那种样子,不知道会不会很挫= =
代码:
#include<cstdio>
#include<cstring>
#include<iostream>
typedef int mType;
using namespace std;
const int mm=5555;
/**表示点或向量*/
struct Tpoint
{
    mType x,y;
    Tpoint(){}
    void fill(mType _x,mType _y)
    {
        x=_x,y=_y;
    }
};
/**有起点和终点的向量*/
struct Tvector
{
    Tpoint a,b;
};
/**生成一个点P到点Q的向量*/
Tpoint MakeVector(Tpoint P,Tpoint Q)
{
    Tpoint tmp;
    tmp.x=Q.x-P.x;
    tmp.y=Q.y-P.y;
    return tmp;
}
/**向量P与Q的叉积PQ*/
mType CrossProduct(Tpoint P,Tpoint Q)
{
    return P.x*Q.y-P.y*Q.x;
}
/**向量QP与向量QR的叉积,用来判断向量的拐向
*  返回值: >0 向右拐, <0 向右拐,等于零同向或反向
*/
mType MultiCross(Tpoint P,Tpoint Q,Tpoint R)
{
    return CrossProduct(MakeVector(Q,P),MakeVector(Q,R));
}
Tvector g[mm];
Tpoint h[mm];
int v[mm],sum[mm];
mType x1,y1,x2,y2,u,l;
int i,j,k,n,m;
int main()
{
    scanf("%d",&n);
    while(1)
    {
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
        for(i=0;i<n;++i)
        {
            scanf("%d%d",&u,&l);
            g[i].a.fill(u,y1);
            g[i].b.fill(l,y2);
        }
        for(i=0;i<m;++i)
            scanf("%d%d",&h[i].x,&h[i].y);
        memset(v,0,sizeof(v));
        memset(sum,0,sizeof(sum));
        for(k=i=0;i<n;++i)
            for(j=0;j<m;++j)
                if(!v[j]&&MultiCross(g[i].a,g[i].b,h[j])>0)
                {
                    ++sum[i];
                    v[j]=1;
                    ++k;
                }
        sum[n]=m-k;
        for(i=0;i<=n;++i)
            printf("%d: %d\n",i,sum[i]);
        scanf("%d",&n);
        if(n)puts("");
        else break;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值