放玩具,用几何方法求解+二分

Calculate the number of toys that land in each bin of a partitioned toy box.

计算每一个玩具箱里面玩具的数量
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.
妈妈和爸爸有一个问题,他们的孩子约翰从来没有在玩完玩具后把玩具都放好,他们有了约翰一个矩形的箱子用来放他的玩具,但是约翰很叛逆,他服从了他父母,不过只是简单地把玩具扔进了箱子里。所有的玩具都搞混了,并且约翰不可能找到他最喜欢的玩具。
John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

约翰的父母想出了如下的注意,他们在箱子里放了纸板进行分区,即使约翰不停地把玩具扔进箱子里,至少玩具被扔进不同的垃圾箱并保持分开,下图展现了样例玩具箱的俯视图。

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

对于这个问题,当约翰把玩具扔进箱子里时,你被要求确定有多少个玩具被扔进了分区。

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

 输入文件包含一个或多个问题,第一行是第一个问题包含6个数,n,m,x1,x2,y1,y2,纸板分区的数目为n(0 < n <= 5000),玩具的数量是m(0<m<5000),箱子左上角的坐标为(x1,y1),右下角的坐标为(x2,y2)。以下N行,每行包含两个整数,Ui Li,表示第i个纸板分区的结束是在坐标(UI,y1)和(Li,y2)。你可以假设纸板分区彼此不相交,它们是从左到右按排序顺序指定的。接下来的m行每行包含两个整数,Xj Yj指定该位置被第j个玩具落在了箱子里,玩具位置的顺序是随机的。你可以假设没有玩具会准确地落在硬纸板的隔板上或盒子的外面(就是所有玩具肯定都会掉进箱子里面),输入由一个单0组成的行终止。

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

每个问题的输出将是玩具箱中每个独立的箱子的一行。对于每一个箱子,打印它的箱子的号码,后面是冒号和一个空格,后面跟着丢进箱子的玩具数量。箱编号从0(最左边箱子)N(最右边的箱子)。用一条空行分隔不同问题的输出。

Sample Input
5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0
Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2
转载原文

#include <cstdio>  
#include <cstdlib>  
#include <cstring>  
using namespace std;  
 
struct point//此结构体用来记录坐标 
{  
    int x,y;  
};  
 
struct Node//此结构体用来记录隔板上下的点 
{  
    point a,b;  
}A[5010];  
 
int pos[5010];  
 
bool judge(int xx,int yy,int mid)
{  
    int ans=(A[mid].a.x-xx)*(A[mid].b.y-yy)-(A[mid].a.y-yy)*(A[mid].b.x-xx);//本题判断核心 
	//判断已知的两点坐标的连线和另外一个已知点的位置,如果ans>0,则已知点在连线的右侧,否则在连线的左侧
    if(ans<0) 
		return false;  
    return true;  
}  
 
void search(int xx,int yy,int n)
{  
    int left=0,right=n-1;  
    while(left<=right)
	{  
        int mid=(left+right)>>1;//此处的>>1可以等价理解为/2
		//int mid=(left+right)/2; 
        if(judge(xx,yy,mid))
		{  
            left=mid+1;//进入此条件说明点的mid所在的那条线的右侧  
        }  
        else 
		{  
        	right=mid-1;//进入此条件说明点的mid所在的那条线的左侧   
        }  
    }  
    pos[left]++;//记录不同箱子所得到的玩具数量  
}  
 
int main()  
{  
    //freopen("input.txt","r",stdin);
	int n,m,i,j,x1,x2,y1,y2;  
    while(scanf("%d",&n),n)//多组输入,且n不为0 
	{  
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);  
        for(i=0;i<n;++i)
		{  
            int xd,xu;  
            scanf("%d%d",&xu,&xd);  
            A[i].a.x=xu;  
            A[i].a.y=y1;  
            A[i].b.x=xd;  
            A[i].b.y=y2;  
        }//存储了隔板的位置  
        
		memset(pos,0,sizeof(pos));  
        
		for(i=0;i<m;++i)
		{  
            int xx,yy;  
            scanf("%d%d",&xx,&yy);  
            search(xx,yy,n);//进入search函数,分析该玩具被扔进了第几号箱子里  
        }
		  
        for(i=0;i<=n;++i)  
            printf("%d: %d\n",i,pos[i]);  
          
        printf("\n");  
    }  
    return 0;  
} 

原博主写的很好啦(膜拜一下),就是有一点我感觉不妥,这个ans这样写好理解点(因为我不理解它写的是怎么回事咳咳,但是能过)

bool judge(int xx,int yy,int mid)
{
	int ans=(A[mid].a.y -yy )*(xx-A[mid].b.x)-(yy-A[mid].b.y)*(A[mid].a.x -xx);
	//斜率如果用除法直接求就会忽略斜率不存在的情况,要保证用乘法又不变号就要保证两式相乘前分母必须为正数 
	if(ans>0)
		return true;
	return false;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值