poj 1696 Space Ant(叉积的应用)

Space Ant
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2025 Accepted: 1258

Description

The most exciting space discovery occurred at the end of the 20th century. In 1999, scientists traced down an ant-like creature in the planet Y1999 and called it M11. It has only one eye on the left side of its head and just three feet all on the right side of its body and suffers from three walking limitations: 
  1. It can not turn right due to its special body structure. 
  2. It leaves a red path while walking. 
  3. It hates to pass over a previously red colored path, and never does that.

The pictures transmitted by the Discovery space ship depicts that plants in the Y1999 grow in special points on the planet. Analysis of several thousands of the pictures have resulted in discovering a magic coordinate system governing the grow points of the plants. In this coordinate system with x and y axes,  no two plants share the same x or y
An M11 needs to eat exactly one plant in each day to stay alive. When it eats one plant, it remains there for the rest of the day with no move. Next day, it looks for another plant to go there and eat it. If it can not reach any other plant it dies by the end of the day. Notice that it can reach a plant in any distance. 
The problem is to find a path for an M11 to let it live longest. 
Input is a set of (x, y) coordinates of plants. Suppose A with the coordinates (xA, yA) is the plant with the least y-coordinate. M11 starts from point (0,yA) heading towards plant A. Notice that the solution path should not cross itself and all of the turns should be counter-clockwise. Also note that the solution may visit more than two plants located on a same straight line. 

Input

The first line of the input is M, the number of test cases to be solved (1 <= M <= 10). For each test case, the first line is N, the number of plants in that test case (1 <= N <= 50), followed by N lines for each plant data. Each plant data consists of three integers: the first number is the unique plant index (1..N), followed by two positive integers x and y representing the coordinates of the plant. Plants are sorted by the increasing order on their indices in the input file. Suppose that the values of coordinates are at most 100.

Output

Output should have one separate line for the solution of each test case. A solution is the number of plants on the solution path, followed by the indices of visiting plants in the path in the order of their visits.

Sample Input

2
10
1 4 5
2 9 8
3 5 9
4 1 7
5 3 2
6 6 3
7 10 10
8 8 1
9 2 4
10 7 6
14
1 6 11
2 11 9
3 8 7
4 12 8
5 9 20
6 3 2
7 1 6
8 2 13
9 15 1
10 14 17
11 13 19
12 5 18
13 7 3
14 10 16

Sample Output

10 8 7 3 4 9 5 6 2 1 10
14 9 10 11 5 12 8 7 6 13 4 14 1 3 2

Source

题目:http://poj.org/problem?id=1696

题意:坐标上有一些点,要求从0,ay(ay是所有点最低的y坐标)起,连线,不能像右拐,不能和之前的线相交,求最多连接到的点数,和路径

分析:一开始看挺麻烦的,一大堆条件,后来仔细分析了下,答案一定是连到所有点啦,只要从最外围往里面包,然后就是判断一条直线的情况,虽然不知道数据有没有,一条直线上要判断距离。。。又一个1Y

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
typedef int mType;
struct Tpoint
{
    mType x,y;
    Tpoint(){}
    Tpoint(mType _x,mType _y):x(_x),y(_y){}
};
Tpoint MakeVector(Tpoint P,Tpoint Q)
{
    return Tpoint(Q.x-P.x,Q.y-P.y);
}
mType CrossProduct(Tpoint P,Tpoint Q)
{
    return P.x*Q.y-P.y*Q.x;
}
mType MultiCross(Tpoint P,Tpoint Q,Tpoint R)
{
    return CrossProduct(MakeVector(Q,P),MakeVector(Q,R));
}
mType Get(Tpoint P,Tpoint Q)
{
    return (P.x-Q.x)*(P.x-Q.x)+(P.y-Q.y)*(P.y-Q.y);
}
Tpoint g[55];
int q[55],v[55];
int i,j,tmp,n,t;
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        g[0]=Tpoint(0,1e9);
        for(i=1;i<=n;++i)
        {
            scanf("%d%d%d",&j,&g[i].x,&g[i].y);
            g[0].y=min(g[0].y,g[i].y);
        }
        memset(v,0,sizeof(v));
        memset(q,0,sizeof(q));
        for(i=1;i<=n;++i)
            for(j=1;j<=n;++j)
                if(!v[j])
                {
                    if(q[i])
                    {
                        tmp=MultiCross(g[j],g[q[i-1]],g[q[i]]);
                        if(tmp<0)continue;
                        if(!tmp&&Get(g[q[i-1]],g[q[i]])<Get(g[q[i-1]],g[j]))continue;
                    }
                    v[q[i]]=0,v[q[i]=j]=1;
                }
        q[0]=n;
        for(i=0;i<=n;++i)
            printf("%d%c",q[i],i<n?' ':'\n');
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值