usaco 5.4 Canada Tour(双线程DP)

Canada Tour

You have won a contest sponsored by an airline. The prize is a ticket to travel around Canada, beginning in the most western point served by this airline, then traveling only from west to east until you reach the most eastern point served, and then coming back only from east to west until you reach the starting city. No city may be visited more than once, except for the starting city, which must be visited exactly twice (at the beginning and the end of the trip). You are not allowed to use any other airline or any other means of transportation.

Given a list of cities served by the airline and a list of direct flights between pairs of cities, find an itinerary which visits as many cities as possible and satisfies the above conditions beginning with the first city and visiting the last city on the list and returning to the first city.

PROGRAM NAME: tour

INPUT FORMAT

Line 1:The number N of cities served by the airline and the number V of direct flights that will be listed. N will be a positive integer not larger than 100. V is any positive integer.
Lines 2..N+1:Each line contains a name of a city served by the airline. The names are ordered from west to east in the input file. There are no two cities in the same meridian. The name of each city is a string of, at most, 15 digits and/or characters of the Latin alphabet; there are no spaces in the name of a city.
Lines N+2..N+2+V-1:Each line contains two names of cities (taken from the supplied list), separated by a single blank space. This pair is connected by a direct, two-way airline flight.

SAMPLE INPUT (file tour.in)

8 9	
Vancouver		
Yellowknife	
Edmonton
Calgary
Winnipeg
Toronto	
Montreal
Halifax	
Vancouver Edmonton
Vancouver Calgary	
Calgary Winnipeg
Winnipeg Toronto
Toronto Halifax
Montreal Halifax
Edmonton Montreal
Edmonton Yellowknife
Edmonton Calgary

OUTPUT FORMAT

Line 1:The number M of different cities visited in the optimal itinerary. Output 1 if no itinerary is possible.

SAMPLE OUTPUT (file tour.out)

7

Namely: Vancouver, Edmonton, Montreal, Halifax, Toronto, Winnipeg, Calgary, and Vancouver (but that's not a different city). 

题意:有n个城市,城市间有航线,现在你从最东边的城市到最西边的城市,然后再返回,途中不能经过城市超过两次,问最多能访问几个城市

分析:经典的题目,直接用双线程DP,当然也可以用网络流来做

DP的话有方程

f[k][j]=max{f[i][j]+1}(0<j<i<k  且 i到k有航线)

f[k][i]=max{f[i][j]+1}(0<j<i<k  且 j到k有航线)

当然要特殊处理 起点和终点。。。

代码:

/*
ID: 15114582
PROG: tour
LANG: C++
*/
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int mm=111;
int f[mm][mm],g[mm][mm];
char city[mm][22],a[22],b[22];
int i,j,k,n,m,ans;
int GetID(char a[])
{
    for(int i=1;i<=n;++i)
        if(!strcmp(city[i],a))return i;
    return 0;
}
int main()
{
    freopen("tour.in","r",stdin);
    freopen("tour.out","w",stdout);
    while(~scanf("%d%d",&n,&m))
    {
        for(i=1;i<=n;++i)
            scanf("%s",city[i]);
        memset(g,0,sizeof(g));
        while(m--)
        {
            scanf("%s%s",a,b);
            i=GetID(a),j=GetID(b);
            g[i][j]=g[j][i]=1;
        }
        memset(f,0,sizeof(f));
        f[1][1]=1;
        for(i=1;i<n;++i)
            for(j=1;j<=i;++j)
                for(k=i+1;k<=n;++k)
                    if(f[i][j]>0)
                    {
                        if(g[i][k])f[k][j]=max(f[k][j],f[i][j]+1);
                        if(g[j][k])f[k][i]=max(f[k][i],f[i][j]+1);
                    }
        ans=1;
        for(i=1;i<n;++i)
            if(g[i][n])ans=max(ans,f[n][i]);
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值