Hbase在PowerLinux平台异常:libjffi-1.0.so包不存在的解决方法

在PowerLinux平台使用Hbase的时候,经常碰到如下问题:

Hbase编译完成后,在X86平台能够正常使用,但是PowerLinux平台会出现如下的错误:

root@rhel1-> hbase shell

2014-09-28 03:41:20,547 INFO  [main] Configuration.deprecation:hadoop.native.lib is deprecated. Instead, use io.native.lib.available
java.lang.RuntimeException: java.lang.UnsatisfiedLinkError: Could not locatestub library in jar file.  Tried [jni/ppc64-Linux/libjffi-1.0.so,/jni/ppc64-Linux/libjffi-1.0.so]

错误原因以及解决方法:

jruby-complete-1.6.8.jar里面的libjffi-1.0.so文件没有ppc64的版本,需要解压该jar包,在jni目录下建一个新的ppc64-Linux目录,把so文件拷贝进去即可。

如果没有找到相关的so文件,可以留言我传给你。


阅读更多
换一批

没有更多推荐了,返回首页