POJ 1442 优先队列

题目:
Black Box
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4364 Accepted: 1761
Description


Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 


ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 


Let us examine a possible sequence of 11 transactions: 


Example 1 


N Transaction i Black Box contents after transaction Answer 


      (elements are arranged by non-descending)   


1 ADD(3)      0 3   


2 GET         1 3                                    3 


3 ADD(1)      1 1, 3   


4 GET         2 1, 3                                 3 


5 ADD(-4)     2 -4, 1, 3   


6 ADD(2)      2 -4, 1, 2, 3   


7 ADD(8)      2 -4, 1, 2, 3, 8   


8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   


9 GET         3 -1000, -4, 1, 2, 3, 8                1 


10 GET        4 -1000, -4, 1, 2, 3, 8                2 


11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   


It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 




Let us describe the sequence of transactions by two integer arrays: 




1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 


2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 


The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 




Input


Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.
Output


Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.
Sample Input


7 4
3 1 -4 2 8 -1000 2
1 2 6 6
Sample Output


3
3
1
2
Source


Northeastern Europe 1996


题意:
给定一个序列,每次插入序列中的一个数,给定另一个序列,表示在插入第几个数的时候取数,第一次取最小的,第二次取第二小的,依次,每次取数就将取出的数输出。




用一个优先队列存储前K小的数,大数在前,用另一个优先队列存储第K+1小的数到最大的数,小的在前,每次拿到一个数,判断第一个优先队列中的数满不慢K个,不满的话就插入,慢的话判断一下这个数和第一个队列中的第一个的大小关系,如果这个数打,就插入到第二个优先队列中,如果这个数小,就把第一个队列的队首插入到第二个队列中,并弹出,然后把这个新数插入。
在取的时候,如果第一个队列里的个数小于K,则先把第二个队列里的队首弹出到第一个队列中,然后取第一个队列的队首,如果够K个,则直接取队首








源代码:

#include<iostream>
#include<set>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

int a[30005];
int b[30005];

int main()
{
	int m,n;
	while(~scanf("%d%d",&m,&n))
	{
		for(int i=1;i<=m;i++)
		{
			scanf("%d",&a[i]);
		}
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&b[i]);
		}
		priority_queue<int,vector<int>,greater<int> >q;
		priority_queue<int>q1;
		int i=0;
		int j=1;
		int k=1;
		int l=1;
		int x;
		while(j<=n)
		{
			if(i==b[j])
			{
				int res;
				j++;
				if(q1.size()<k)
				{
					res=q.top();
					q1.push(res);
					q.pop();

				}
				res=q1.top();
				printf("%d\n",res);
				k++;
			}
			else
			{
				i++;
				if(q1.size()<k)
				{
					q.push(a[i]);
					int x=q.top();
					q.pop();
					q1.push(x);
				}
				else if(q1.top()>a[i])
				{
					int x=q1.top();
					q1.pop();
					q1.push(a[i]);
					q.push(x);
				}
				else
				{
					q.push(a[i]);
				}
			}
		}
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值