Poj1442 Black Box 二叉堆做法详解

Black Box
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14267 Accepted: 5831

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2

Source

Northeastern Europe 1996

题目理解:每次输出给定数列中第k小的数,并且k的值递增,数列也在不断增加。

算法分析:

  1. 暴力解法:完全的每次读入后都进行排序,按照排序后的结果输出第k小的值,每次排序O(nlogn),n次复杂度为O(n^2logn)。
  2. 稍微好一点的暴力做法:只用一个二叉堆,动态维护数列的最小值,复杂度O(logn),虽然这里复杂度降低了,随着k的增大,每次需要pop掉和push进的数会越来越多(不断地pop来找到第k小,输出后还得把原来pop出来的数再push进去),所以复杂度仍然很高。
  3. 两个二叉堆,一个大根堆一个小根堆。作用为维护第k个值左边的数和右边的数,其中左边的数的最大值也不会超过右边的数的最小值,如果满足这个条件,就说明在一个单增的数列中,k这个位置的这个数字是合适的。由于每次k的值查询后都会递增1,所以每次查询后手动将k这个位置向右移动一位即可。具体看代码!!
 
#include<cstdio>  
#include<cstring>  
#include<algorithm>  
#include<queue>  
using namespace std;  
const int SIZE = 30010;  
int a[SIZE],b[SIZE];  
priority_queue<int, vector<int> , less<int> > gq; //大根堆  
priority_queue<int, vector<int> , greater<int> > lq; //小根堆  
int main()   
{  
    int n,m;  
    scanf("%d%d",&n,&m);  
    for(int i=1;i<=n;i++)  
        scanf("%d",&a[i]);  
    for(int i=1;i<=m;i++)  
        scanf("%d",&b[i]);  
    int cnt=1;  
    for(int i=1;i<=m;i++)  
    {  
        while(cnt<=b[i])  
        {  
            lq.push(a[cnt]);  
            if(!gq.empty()&&gq.top()>lq.top())  
//即:当且仅当插入的数小于原来第k小的数时(即当插入的数小于,原来第k小的数之前的大根堆中的最大值),第k小的数的具体数值才需要改变。比如-1,2,3中插入了4并不会影响第2小的数是2,但插入了-2后第2小的数会变为-1.  
            {  
                int t=gq.top();  
                int t1=lq.top();  
                gq.pop();lq.pop();  
                gq.push(t1);lq.push(t);  
            }  
            cnt++;  
        }  
        printf("%d\n",lq.top());  
        int t=lq.top();  
        lq.pop();  
        gq.push(t);//手动向右移动一位,相当于查询后k自增1。  
    }  
    return 0;  
}  





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值