hdu 1003 Max Sum【一维数组最大连续和】

67 篇文章 0 订阅
20 篇文章 0 订阅

链接:



Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 113473    Accepted Submission(s): 26241


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
   
   
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
   
   
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 


算法:做的时候感觉是贪心,本质应该也算是DP了


思路:


      对于数字:a[0]----a[n-1]
     状态转移方程:dp[0] = a[0]
                      dp[i] = max(dp[i-1], 0)+a[i]
                      最后遍历 dp[] 找出最大的 dp[i] 就是这一行数的最大连续和
     状态转移方程样例分析:
       a[]: 6 -1 3 -10 8 7
       dp[]:6  5 8  0  8 15
     关于下标,判断dp[i-1]是不是 0 的时候更新就可以了,这么写主要是为了方便下一题的描述

    事实上直接  a[0] = a[0]
                      a[i] = max(a[i-1], 0) + a[i]  更新时注意下下标的处理就可以了,最后再输出最大的 a[i] 


code:

#include<stdio.h>

int main()
{
    int T;
    int n;
    int a; //存输入的数
    scanf("%d", &T);
    for(int kcase = 1; kcase <= T; kcase++)
    {
        scanf("%d", &n);

        scanf("%d", &a);
        int sum = a; //最大值
        int Max = a; //中间比较变量

        int index1 = 1; //起点
        int index2 = 1; //终点
        int st = 1; //中间比较变量的起点

        if(Max < 0) //注意
        {
            Max = 0;
            st = 2;
        }

        for(int i = 2; i <= n; i++)
        {
            scanf("%d", &a);

            Max += a;

            if(Max > sum)
            {
                sum = Max;
                index1 = st;
                index2 = i;
            }

            if(Max < 0) //注意别加 else 否则上面判断后,不会进入下面, 开始没有注意,坑了很久
            {
                Max = 0;
                st = i+1;
            }

        }

        printf("Case %d:\n", kcase);
        printf("%d %d %d\n", sum, index1, index2);
        if(kcase != T) printf("\n"); //注意格式
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值