PAT 1003. Emergency (25)

1003. Emergency (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4

分析: 这道题就是应用dijkstra求c1到c2的最短路径. 有点变化的是, 要额外创建数组记录每个点(city)的总最短路径条数, 以及在各个最短路径中能聚集最大的team数量(最大权重). 另外要注意判断c1,c2是同一个城市时候的特殊情况.


渣代码如下:

#include <iostream>
#include <cstring>
using namespace std;
#define MAX 16843009
#define max(x,y) ((x)>(y)?(x):(y))
int main(void)
{
	int N,M,c1,c2,i,j,k,l;
	cin>>N>>M>>c1>>c2;
	int team[N]; 
	int distance[N][N]; 
	int dist[N];
	int visited[N];
	int path_number[N];
	int total_team[N];
	memset(distance,1,sizeof(distance)); //let each element  be 16843009
	for(i = 0; i < N; i++)
		cin>>team[i];
	for(i = 0; i < M; i++)
	{
		cin>>j>>k>>l;
		distance[j][k]=l;
		distance[k][j]=l;
	}
	for(i = 0; i < N; i++)
	{
		visited[i]=0;
		dist[i]=distance[c1][i];
		total_team[i]=team[i];
		path_number[i] = 1;
	}
	visited[c1]=1;
	dist[c1]=0;
	if(c2==c1){
		cout<<1<<" "<<team[c1];
		return 0;
	}
	while(visited[c2]==0)
	{
		l = MAX;
		for(j = 0; j < N; j++)
		{
			if(visited[j]==0 && dist[j]<l)
			{
				l = dist[j];
				k = j;
			}
		}
		visited[k]=1;
		for(j = 0; j < N; j++)
		{
			if(visited[j]==0 && distance[j][k]!=MAX)	
			{
				if(dist[j] > dist[k]+distance[j][k])
				{
					dist[j] = dist[k]+distance[j][k];
					path_number[j] = path_number[k];
					total_team[j] = total_team[k]+team[j];
				}
				else if(dist[j]==dist[k]+distance[j][k])
				{
					path_number[j]+=path_number[k];
					total_team[j] = max(total_team[j],total_team[k]+team[j]);
				}
			}
		}
	}
	total_team[c2]+=team[c1];
	cout<<path_number[c2]<<" "<<total_team[c2];
	return 0;	

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值