PAT 1095. Cars on Campus (30)

1095. Cars on Campus (30)

时间限制
220 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Zhejiang University has 6 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<= 10000), the number of records, and K (<= 80000) the number of queries. Then N lines follow, each gives a record in the format

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each "in" record is paired with the chronologically next record for the same car provided it is an "out" record. Any "in" records that are not paired with an "out" record are ignored, as are "out" records not paired with an "in" record. It is guaranteed that at least one car is well paired in the input, and no car is both "in" and "out" at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:
16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00
Sample Output:
1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

一道常规的模拟问题,首先要处理好in和out之间的关系,把每一个合法的in和out组成一对。什么是“合法”的题目中讲的蛮清楚的,也没什么坑。 

然后为了后面查询的方便,把组成对的数据按照到达时间(也就是in)从小到大排序,因此给出任意时间点T,符合要求的车辆即是到达时间<=T, 并且离开时间>T 的那些车。 

解决了查询以后,就是简单的同车辆记录求和并找出最大值的问题了。 代码如下: 

#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <queue>
#include <map>
#include <set>
#include <vector>
using namespace std;
int timetoint(int hour,int min,int sec)
{
	return hour*3600+min*60+sec;
}
void inttotime(int time)
{
	string result;
	int hour=time/3600;
	time%=3600;
	int min=time/60;
	int sec=time%60;
	printf("%02d:%02d:%02d",hour,min,sec);
}
typedef struct node{
	int begin;
	int end;
	string id;
}node;
map<string,set<int,greater<int> > > in;
map<string,set<int> > out;
vector<node> paired;
bool cmp(node a,node b)
{
	return a.begin<b.begin;
}
void getpaired()
{
	map<string,set<int> >::iterator mit;
	for(mit=out.begin();mit!=out.end();mit++)
	{
		set<int>::iterator sit;
		for(sit=mit->second.begin();sit!=mit->second.end();sit++)
		{
			if(in.count(mit->first)<=0 || in[mit->first].size()<=0)
				break;
			else
			{
				set<int>::iterator sit2;
				for(sit2=in[mit->first].begin();sit2!=in[mit->first].end();sit2++)
				{
					if(*sit2<*sit)
					{
						node temp;
						temp.begin=*sit2;
						temp.end=*sit;
						temp.id=mit->first;
						paired.push_back(temp);
						in[mit->first].erase(sit2,in[mit->first].end());
						break;
					}
				}
			}
		}
	}
}
void findMax()
{
	map<string,int> result;
	for(int i=0;i<paired.size();i++)
	{
		if(result.count(paired[i].id)<=0)
			result[paired[i].id]=paired[i].end-paired[i].begin;
		else
			result[paired[i].id]+=paired[i].end-paired[i].begin;
	}
	vector<string> theid;
	int MAX=0;
	map<string,int>::iterator it;
	for(it=result.begin();it!=result.end();it++)
	{
		if(it->second>MAX)
		{
			theid.clear();
			theid.push_back(it->first);
			MAX=it->second;
		}
		else if(it->second==MAX)
			theid.push_back(it->first);
	}
	sort(theid.begin(),theid.end());
	for(int i=0;i<theid.size();i++)
		cout<<theid[i]<<" ";
	inttotime(MAX);
}
void query(int time)
{
	int count=0;
	for(int i=0;i<paired.size();i++)
	{
		if(paired[i].begin>time)
			break;
		else if(paired[i].end>time)
			count++;
	}
	printf("%d\n",count);
}
int main(void)
{
	int N,K,i;
	cin>>N>>K;
	int hour,min,sec;
	for(i=0;i<N;i++)
	{
		string id,method;
		cin>>id;
		scanf("%d:%d:%d",&hour,&min,&sec);
		int time=timetoint(hour,min,sec);
		cin>>method;
		if(method=="in")
			in[id].insert(time);
		else
			out[id].insert(time);
	}
	getpaired();	
	sort(paired.begin(),paired.end(),cmp);
	while(K--)
	{
		scanf("%d:%d:%d",&hour,&min,&sec);
		int time=timetoint(hour,min,sec);
		query(time);
	}
	findMax();
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值