并查集 最小生成树(prime )

畅通工程

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 
Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
注意:两个城市之间可以有多条道路相通,也就是说 
3 3 
1 2 
1 2 
2 1 
这种输入也是合法的 
当N为0时,输入结束,该用例不被处理。 
Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。 
Sample Input
4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0
Sample Output
1
0
2
998


        
  
Huge input, scanf is recommended
 
 
#include<iostream>
#include<stdlib.h>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<cmath>
using namespace std;
int father[1010];  
  
void initial(int n)    //初始化  
{  
    for(int i=1;i<=n;i++)  
        father[i]=i;  
}  
  
int find(int x)    //查找  
{  
    while(father[x]!=x)  
        x=father[x];  
  
    return x;  
}  
  
void combine(int a,int b)   //合并  
{  
    int tmpa=find(a);  
    int tmpb=find(b);  
  
    if(tmpa!=tmpb)  
        father[tmpa]=tmpb;  
}  
  
int main()  
{  
    int i,n,m,a,b,tmp;  
  
    while(cin>>n,n)  
    {  
        initial(n);  
  
        cin>>m;  
  
        for(i=1;i<=m;i++)  
        {  
            cin>>a>>b;  
            combine(a,b);  
        }  
  
        tmp=0;  
        for(i=1;i<=n;i++)   //确定连通分量个数  
        {  
            if(father[i]==i)  
                tmp++;  
        }  
  
        cout<<tmp-1<<endl;  
    }  
  
    return 0;  
}  
还是畅通工程

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。 
Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。 
当N为0时,输入结束,该用例不被处理。 
Output
对每个测试用例,在1行里输出最小的公路总长度。 
Sample Input
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
Sample Output
3
5


        
  
Huge input, scanf is recommended.
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=10005;
struct node
{
    int from,to,len;
} edge[maxn];//储存边的数据结构
int n,fa[maxn],m,ans,q;
bool cmp(node a,node b)
{
    return a.len<b.len;    //边按从小到大的顺序排列
}
int Find(int x)
{
    if(fa[x]==x) return x;
    return fa[x]=Find(fa[x]);
}
void Merge(int x,int y)
{
    x=Find(x),y=Find(y);
    if(x!=y) fa[y]=x;
}
int kruskal()
{
    sort(edge,edge+m,cmp);//边排序
    for(int i=0; i<=n; i++) fa[i]=i; //初始化并查集
    ans=0;
    for(int i=0; i<m; i++) //一条边的两个端点不在同一个集合,则选它,并合并端点
        if(Find(edge[i].from)!=Find(edge[i].to))
        {
              Merge(edge[i].from,edge[i].to);
              ans+=edge[i].len;
        }

    return ans;
}
int main()
{
    while(cin>>n,n)
    {
        m=n*(n-1)/2;
        for(int i=0; i<m; i++) cin>>edge[i].from>>edge[i].to>>edge[i].len;
        cout<<kruskal()<<endl;
    }
    return 0;
}

How Many Tables

 
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4

     
     

How Many Tables

 
      
      
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.  One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.  For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4

#include<iostream>
#include<stdlib.h>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<math.h>
#include<time.h>
using namespace std;
int f[1010];
int get(int x)
{
    if(f[x]==x)
        return x;
    else
    return f[x]=get(f[x]);
}
int bing(int u,int v)
{
    int t1=get(u);
    int t2=get(v);
    if(t1!=t2)
        f[t1]=t2;
}
int main()
{
    int t,a,b,sum;
    cin>>t;
    while(t--)
    {
        int n,m;
        cin>>n>>m;
        for(int i=1;i<=n;i++)
            f[i]=i;
        for(int i=0;i<m;i++)
        {
            cin>>a>>b;
            bing(a,b);
        }
        sum=0;
        for(int i=1;i<=n;i++)
        {
            if(f[i]==i)
                sum++;
        }
        cout<<sum<<endl;
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值