Flash Builder 4 和 eclipse 安装的问题。

     以前用的是fx3的版本。想换成Flash Builder 4。把eclipse也换成最新的。各种倒腾了一天。留下了血流教训。

1.安装前请先确认版本的问题:

  32位的eclipse对应32位的Flash Builder 4 或者Flash Builder 4.6。

  64eclipse对应64位的Flash Builder 4.6.

强烈推荐使用第一种。为什么?因为我用第二种遇到了各种奇怪的问题。

可能的原因是:

1.Flash Builder 不支持64位的。(这个我不确定,可能新版本有。)

2.还是版本的问题,最新的Flash Builder 4.6以及以上的。如果flesh sdk 用 3.5的话。会看不到desgin模式。就是看不到效果图。因为它不支持3.6版本以前的。(这个有谁愿意去考证一下,我试了一下,可能是这个原因,也可能是我的其他错误。)

 

附:(同样适用于Flash Builder 4)

破解方法:

Flash Builder 4.6 破解方法的实践

建议:作为草根一级,买不起正版,只能先拿破解版练练手了,如果商业的话,请用正版。

【转】http://hi.baidu.com/cm186man/blog/item/148658ce557c0323b700c853.html

具体步骤如下:
1.
Adobe官网下载FlashBuilder 4.6,有简体中文版;

语言:简体中文(Simplified)
http://trials3.adobe.com/AdobeProducts/FLBR/4_6/win32/FlashBuilder_
4_6_LS10.exe

2.
安装时,不用序列号,直接选择安装试用版;

3.
安装完成后在安装目录下依次修改下列3个文件:

(1).eclipse\plugins\com.adobe.flexbuilder.project_
4.6.0.328916\META-INF下面的MANIFEST.MF修改:

Bundle-Version: 0.0.0

 (2).eclipse\features\com.adobe.flexide.feature_
4.6.0.328916下面的feature.xml修改:

<plugin
        id="com.adobe.flexbuilder.project"
        download-size="0"
        install-size="0"
        version="0.0.0"/>

(3).eclipse\plugins\com.adobe.flexbuilder.flex_
4.6.0.328916下面:

复制config.xml并重命名为config_builder.xml

注:以上紫色文字部分为具体的版本号,请跟据实际版本号进行查找

修改完成之后,再启动Adobe Flash Builder 4.6,恭喜你,你会发现自己彻底拥有了这款RIA工具了。

 

 

 

 

相关推荐
©️2020 CSDN 皮肤主题: 技术黑板 设计师:CSDN官方博客 返回首页