POJ 1159 Palindrome

126 篇文章 2 订阅

题目的大意是:给你一个长度为n的字符串,让你判断一下最少加入几个字符之后会使得字符串成为一个回文字符串。

题意很简单,其实解法也很简单啊,就是正向数组,与反向数组求一个最长公共子序列,因为这样就可以找到已经匹配了的字符了啊,剩下的就是需要添加的啊。就是一个求最公共子序列,然后输出剩下的值。

但是比较坑的是int型的5000*5000的数组会超内存的啊、、听说用short 可以水过去啊、、但是崔老师说了啊,不能水啊,所以在崔老师的引导下敲了一个貌似叫什么滚动数组的东东,挺好用的啊、、就很简单的过了啊。。。其实期间因为我乱用swap,wa了好几次啊。。sad。。。。

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 48859 Accepted: 16791

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2
#include <stdio.h>
#include <string.h>
#include <cmath>
#include <iostream>
#include <stdlib.h>

using namespace std;

int dp1[5005], dp2[5005];
int main()
{
    int k, i, j;
    char s[5005], str[5005];
    while(~scanf("%d",&k))
    {
        cin >> s;
        for(i = 0; i < k; i++)
            str[k-1-i] = s[i];
        //cout << s << endl << str << endl;
        memset(dp1 , 0 , sizeof(dp1));
        for(i = 1; i <= k; i++)
        {
            //memset(dp2 , 0 , sizeof(dp2));
            for(j = 1; j <= k; j++)
            {
                if(s[i-1] == str[j-1])
                    dp2[j] = dp1[j-1]+1;
                else
                    dp2[j] = max(dp1[j], dp2[j-1]);
            }
            for(int ii = 1; ii <= k; ii++)
                dp1[ii] = dp2[ii];
        }
        printf("%d\n",k-dp2[k]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值