poj1159(回文字串)

Palindrome
Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 41514Accepted: 14146

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

 

#include<stdio.h>
#include<string.h>
short int d[5010][5010];//如果不用short,会超内存
char s[5010];
int min(int x,int y)
{
  return x<y?x:y;
}
int main()
{
  int n,i,j;
  scanf("%d",&n);
  scanf("%s",s);
  memset(d,0,sizeof(d));
  for(i=n-1;i>=0;i--)
    for(j=i+1;j<n;j++)//如果两个游标所指字符相同,向中间缩小范围
    {
      if(s[i]==s[j])
        d[i][j]=d[i+1][j-1];
      else //如果不同,典型的状态转换方程
        d[i][j]=min(d[i+1][j],d[i][j-1])+1;
    }
    printf("%d\n",d[0][n-1]);
  return 0;
}
 
这题还可以用滚动数组做(很多大牛们都是这样做的)
下面是我照这别人代码敲的。。输入格式很容易错哦。。WA了好多次了。。就是scanf()这边。。还是建议用cin>>s1吧。。。下面代码是WA的。。把输入格式改一下就A了。。
  #include<stdio.h>
#include<string.h>
#define max 5005
char s1[max],s2[max];
int maxlen[2][max];
int main()
{
  int n,i,j;
  while(scanf("%d",&n)!=EOF)
  {
    //memset(s1,0,sizeof(s1));
    //memset(s2,0,sizeof(s2));
   
    for(i=1;i<=n;i++)
      scanf("%c",&s1[i]);
    s1[n+1]='\0';
    for(i=1;i<=n;i++)
      s2[i]=s1[n-i+1];
    memset(maxlen,0,sizeof(maxlen));
    int e=0;
    for(i=1;i<=n;i++)
    {
      e=1-e;
      for(j=0;j<=n;j++)
      {
        if(s1[i]==s2[j])
          maxlen[e][j]=maxlen[1-e][j-1]+1;
        else
        {
          int len1=maxlen[e][j-1];
          int len2=maxlen[1-e][j];
          if(len1>len2)maxlen[e][j]=len1;
          else
            maxlen[e][j]=len2;
        }
      }
    }
    printf("%d\n",n-maxlen[e][n]);
  }
  return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值