POJ 2828 Buy Tickets 线段树入门(建树稍微有点抽象)

46 篇文章 0 订阅
38 篇文章 0 订阅

一开始看的时候真的不知道为什么是线段树的题目。后来看到了网上他们的讲解,发现原来也是线段树。

先说一下题意:就是买票插队的问题,有n个人插队,他们都是插道a的后面,所以他的当前位置是a+1,然后也肯能会有别的人插到他的前面去,所以他的最终位置会发生变化,要你说出最终队伍的顺序。

做的方法是:倒过来更新线段树,找到每个人应该存在的位置,然后记录下来,输出就行了。

解释一下算法:

这里建树保存的值是以每个区间内有多少位置是空的个数。然后创建一个数组保存,每个叶子保存的是自己那个位置上有没有被占。根节点上表示是区间上有多少个空的位置。但是要注意的是每个点要插入的位置p,因该满足之前有p个空位,否则他是插进去也会向后移动的。因为那个位置上一定是已经有人存在过了,相反如果没人存在的话,他就不会插在那个位置的后面了啊。理解这个位置的问题就好做多了啊。注意在找p的位置的时候如果左子树所存的空位置的个数,少于你需要的个数的话,你就p - num[site<<1],然后再在有子树里面找。

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 11467 Accepted: 5621

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 10001000
//#define LL __int64
#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898

const int maxn = 2000100;
using namespace std;

int f[maxn*2];
int star[maxn], p[maxn];
int num[maxn];
int t;

void Bulid(int l, int r, int site)
{
    f[site] = r-l+1;
    if(l == r)
        return;
    int mid = (l+r)>>1;
    Bulid(l, mid, site<<1);
    Bulid(mid+1, r, site<<1|1);
}

void Search(int p, int l, int r, int site)
{
    int mid = (l+r)>>1;
    f[site]--;
    if(l == r)
    {
        t = l;
        return;
    }
    if(f[site<<1] >= p)
    {
        Search(p, l, mid, site<<1);
    }
    else
    {
        p -= f[site<<1];//减去左子树中已经包括的空位置
        Search(p, mid+1, r, site<<1|1);
    }
}

int main()
{
    int n;
    while(scanf("%d",&n) != EOF)
    {
        Bulid(1, n, 1);
        for(int i = 1; i <= n; i++)
            scanf("%d %d",&star[i], &num[i]);
        for(int i = n; i >= 1; i--)
        {
            Search(star[i]+1, 1, n, 1);
            p[t] = num[i];
        }
        for(int i = 1; i <= n-1; i++)
            printf("%d ",p[i]);
        printf("%d\n",p[n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值