题意是在n个餐厅之间选择k个地方修建仓库使得,各个餐厅到仓库的距离和最小。
dp[i][j] = min{dp[i][j], dp[i-1][m]+w[m+1][j]}。i表示仓库数目,j表示第几个餐厅。状态转移方程式的意思是:到达j的时候区间(i,j)上所拥有的最小的值。到达j的时候可以选择j位置上不修建仓库dp[i][j] = dp[i][j]。或者选择修仓库那么之前已经有i-1个仓库修建好了,所以只能从i-1到j-1之间选择修建第i个仓库,所以从i-1->j-1枚举m。然后加上一个增量w[m+1][j]。表示加上i后这一段上增加的值的最小。
Fast Food
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 1909 Accepted Submission(s): 815
Problem Description
The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurant and supplying several of the restaurants with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots.
To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers d1 < d2 < ... < dn (these are the distances measured from the company's headquarter, which happens to be at the same highway). Furthermore, a number k (k <= n) will be given, the number of depots to be built.
The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as
must be as small as possible.
Write a program that computes the positions of the k depots, such that the total distance sum is minimized.
To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers d1 < d2 < ... < dn (these are the distances measured from the company's headquarter, which happens to be at the same highway). Furthermore, a number k (k <= n) will be given, the number of depots to be built.
The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as
must be as small as possible.
Write a program that computes the positions of the k depots, such that the total distance sum is minimized.
Input
The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers n and k. n and k will satisfy 1 <= n <= 200, 1 <= k <= 30, k <= n. Following this will n lines containing one integer each, giving the positions di of the restaurants, ordered increasingly.
The input file will end with a case starting with n = k = 0. This case should not be processed.
The input file will end with a case starting with n = k = 0. This case should not be processed.
Output
For each chain, first output the number of the chain. Then output a line containing the total distance sum.
Output a blank line after each test case.
Output a blank line after each test case.
Sample Input
6 3 5 6 12 19 20 27 0 0
Sample Output
Chain 1 Total distance sum = 8
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 10001000
//#define LL __int64
#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
const int maxn = 101000;
using namespace std;
int dp[500][500];
int w[500][500];
int num[500];
int main()
{
int k, n;
int Case = 1;
while(cin >>n>>k)
{
if(!n && !k)
break;
memset(dp, INF, sizeof(dp));
memset(w, 0 , sizeof(w));
memset(num, 0, sizeof(num));
for(int i = 1; i <= n; i++)
cin >>num[i];
for(int i = 1; i <= n; i++)
for(int j = i; j <= n; j++)
for(int m = i; m <= j; m++)
w[i][j] += abs(num[m]-num[(i+j)/2]);
for(int i = 1; i <= n; i++)
dp[1][i] = w[1][i];
for(int i = 2; i <= k; i++)
for(int j = i; j <= n; j++)
for(int m = i-1; m <= j-1; m++)
dp[i][j] = min(dp[i][j], dp[i-1][m]+w[m+1][j]);
cout<<"Chain "<<Case++<<endl;
cout<<"Total distance sum = "<<dp[k][n]<<endl<<endl;
}
return 0;
}