HDU 1147 Pick-up sticks(简单的线段相交)

42 篇文章 0 订阅
15 篇文章 0 订阅

题目的大意是:给你n个线段让你判断,这n个线段按照给定的顺序摆在地上,最上面最后没有线段压着的线段是第几次输入的。

判断线段相交很简单,主要是n的范围很大10^5如果O^2的话肯定会超时,突破点就是最多1000个点在最上面,所以每次得判断一下当前保存的不相交的线段与新的线段是否相交,相交的话就从数组中删除,注意把每次的最后一个加入数组中。

Pick-up sticks

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1939    Accepted Submission(s): 727


Problem Description
Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.
 

Input
Input consists of a number of cases. The data for each case start with 1 ≤ n ≤ 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.
 

Output
For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown.
The picture to the right below illustrates the first case from input.
 

Sample Input
  
  
5 1 1 4 2 2 3 3 1 1 -2.0 8 4 1 4 8 2 3 3 6 -2.0 3 0 0 1 1 1 0 2 1 2 0 3 1 0
 

Sample Output
  
  
Top sticks: 2, 4, 5. Top sticks: 1, 2, 3.
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-10
#define M 1000100
//#define LL __int64
#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898

const int maxn = 100010;
using namespace std;

struct point
{
    double x, y;
    int num;
};

point f[maxn][5];
bool inter(point a, point b, point c, point d)
{
    if(min(a.x, b.x) > max(c.x, d.x) ||
            min(a.y, b.y) > max(c.y, d.y) ||
            min(c.x, d.x) > max(a.x, b.x) ||
            min(c.y, d.y) > max(a.y, b.y)
      ) return false;
    double h, i, j, k;
    h = (b.x-a.x)*(c.y-a.y) - (b.y-a.y)*(c.x-a.x);
    i = (b.x-a.x)*(d.y-a.y) - (b.y-a.y)*(d.x-a.x);
    j = (d.x-c.x)*(a.y-c.y) - (d.y-c.y)*(a.x-c.x);
    k = (d.x-c.x)*(b.y-c.y) - (d.y-c.y)*(b.x-c.x);
    if(h*i <= eps && j*k <= eps)
        return true;
    return false;
}

point que[maxn][5];
int pp[maxn];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(!n)
            break;
        for(int i = 0; i < n; i++)
            {
                scanf("%lf %lf %lf %lf",&f[i][1].x, &f[i][1].y, &f[i][2].x, &f[i][2].y);
                f[i][1].num = i+1;
                f[i][2].num = i+1;
            }
        int p = 0;
        for(int i = 0; i < n; i++)
        {
            int q = 0;
            for(int j = 0; j < p; j++)
            {
                if(!inter(f[i][1], f[i][2], que[j][1], que[j][2]))
                {
                    que[q][1] = que[j][1];
                    que[q++][2] = que[j][2];
                }
            }
            que[q][1] = f[i][1];
            que[q++][2] = f[i][2];
            p = q;
        }
        printf("Top sticks: ");
        for(int i = 0; i < p; i++)
        {
            printf("%d",que[i][1].num);
            if(i != p-1)
            printf(", ");
        }
        printf(".\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值