通用版2.G

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.

Let’s consider a generalized form of the problem above. Given npositive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1n2 and n (1 ≤ n1n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains n positive integers ai (1 ≤ ai ≤ 108 for all is.t. 1 ≤ i ≤ n) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input
1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0
Sample Output
3.500000
562.500000
Hint

This problem has very large input data. scanf and printf are recommended for C++ I/O.

The memory limit might not allow you to store everything in the memory.

#include <iostream>//3360ms
#include <queue>
#include <vector>
#include <cstdio>
using namespace std;
struct cmp
{
    bool operator()(int x,int y)
    {
        return x>y;
    }
};
int main()
{
    int n1,n2,n,i,a;
    double ans;
    while(scanf("%d%d%d",&n1,&n2,&n)){
        if(!n1&&!n2&&!n)break;
        priority_queue<double>little;//从大到小
        priority_queue<double, vector<int>, cmp>big;//从小到大
        ans=0;
        for(i=0;i<=n-1;i++){
            scanf("%d",&a);
            ans+=a;
            little.push(a);
            big.push(a);
            if(big.size()>n1) big.pop();
            if(little.size()>n2) little.pop();
        }
        for(i=0;i<=n1-1;i++){
            ans-=big.top();
            cout<<big.top()<<endl;
            big.pop();
        }
        for(i=0;i<=n2-1;i++){
            ans-=little.top();
            little.pop();
        }
        printf("%.6lf\n",ans/(n-n1-n2));
    }
    return 0;
}

优先队列就是把数字放到队列里会自动排序,默认是按从大到小排序

这道题里从大到小排序的时候,为了保留最小的数,每当队列里的数字超过n1个时,就把优先级最高的数删掉;从小到大排的时候同理

贴一个别人讲解的博客 http://blog.csdn.net/c20182030/article/details/70757660 写的时候没看到这个博客,感觉讲的比较清晰

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值