DFS求给定权值的路径并按非递增顺序输出

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.


Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bi for i=1, ... k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2

10 3 3 6 2

#include<stdio.h>
#include<queue>
#include<vector>
#include<algorithm>
const int maxn=110;
//给出后序和中序求层序
using namespace std;
//静态树
struct Node{
	int data;
	vector<int> child;
	bool operator < (Node A){
		return data>A.data;//便于后面按孩子节点从大到小排序,保证非递增输出
	}
}node[maxn];

bool cmp(int i,int j){
	return node[i].data>node[j].data;
}

//以下可用vector代替,Numpath=vector.size();
int path[maxn];//记录路径上的节点号
int n,m,s;//节点数,非叶节点数,给定权值和
void DFS(int index,int Numpath,int sum){
	//剪枝:1.总和超过了给定权值 2.达到了给定权值,但没有到达叶节点
	if(sum>s)	return;
	if(sum==s){
		if(node[index].child.size()!=0)	return ;//非叶节点
		for(int i=0;i<Numpath;i++){
			printf("%d",node[path[i]].data);
			if(i!=Numpath-1)	printf(" ");
			else printf("\n");
		}
	}
	//sum<s,对所有child进行递归处理,注意要记录入path
	for(int i=0;i<node[index].child.size();i++){
		int child=node[index].child[i];
		path[Numpath]=child;
		DFS(child,Numpath+1,sum+node[child].data);
	}
}



int main(){
	scanf("%d%d%d",&n,&m,&s);
	for(int i=0;i<n;i++){
		scanf("%d",&node[i].data);//题目已经按序进行编号了
	}
	for(int i=0;i<m;i++){
		int temp,num;
		scanf("%d%d",&temp,&num);
		for(int j=0;j<num;j++){
			int chi;
			scanf("%d",&chi);
			node[temp].child.push_back(chi);
		}
		sort(node[temp].child.begin(),node[temp].child.end());
	}

	//切记:对所有数据进行初始化,就像BFS中首先把root入队,这里要把根节点放入path
	path[0]=0;

	DFS(0,1,node[0].data);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值