Stirling公式(pku1423)

Stirling 公式


即:


    Stirling公式的意义在于:当n足够大时,n!计算起来十分困难,虽然有很多关于n!的等式,但并不能很好地对阶乘结果进行估计,尤其是n很大之后,误差将会非常大。但利用Stirling公式可以将阶乘转化成幂函数,使得阶乘的结果得以更好的估计。而且n越大,估计得越准确。


PKU 1423 Big Number


Big Number
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 26811
Accepted: 8557

Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= m <= 10^7 on each line.

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2
10
20

Sample Output

7
19

Source


分析

利用Stirling公式求解n!的位数:易知整数n的位数为[lgn]+1。利用Stirling公式计算n!结果的位数时,可以两边取对数,得:


故n!的位数为:



<span style="font-size:18px;">#include <iostream>
#include <cmath>

using namespace std; 

const double e = 2.7182818284590452354; 
const double pi = 3.141592653589793239; 

double logStirling(int n)
{
	return 0.5*log10(2*pi*n) + n*log10(n/e); 
}

int main(int argc, char *argv[])
{
	int t, m; 
	cin >> t; 
	while (t--)
	{
		cin >> m; 
		cout << (int) logStirling(m)+1 << endl;
	}
	return 0;
}</span>



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值