POJ-3009 Curling 2.0 解题报告(搜索) 冰壶游戏

C - Curling 2.0

Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u
 
Description
On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board

...
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

Hint

 

这个题目用DFS做显然很简单,把所有可行的方案执行一次,逐一比较,更新min值即可。

#include<stdio.h>
#include<string.h>
int map[25][25];
int drx[4]={0,1,0,-1},dry[4]={1,0,-1,0};
int w,h,x1,y1,min;
int DFS(int x,int y, int step);
int main()
{
	while(scanf("%d%d",&w,&h)&& w!=0)
	{
		min=5000;
		for(int i=1;i<=h;i++)
			for(int j=1;j<=w;j++){
				scanf("%d",&map[i][j]);
				if(map[i][j]==2){
					x1=i;y1=j;}
			}
			DFS(x1,y1,0);
			printf("%d\n",min>10?-1:min);
	}
	return 0;
}

int DFS(int x,int y, int step)
{
	int nx,ny;
	if(step>10)return 0;					//把这个放前面会让你节约至少一半的时间;
	for(int i=0;i<4;i++){
		nx=x+drx[i];ny=y+dry[i];
		if(nx>0 && nx<=h && ny>0 && ny<=w && map[nx][ny]!=1){//判断初始方向是否能走;
			do{												 //直线行走;
				if(map[nx][ny]==3){	if(step+1<min) min=step+1;	return 0;}
				nx=nx+drx[i];ny=ny+dry[i];
			}while(nx>0 && nx<=h && ny>0 && ny<=w && map[nx][ny]!=1);
		}
		else continue;						//不能走换方向;
		if(nx<=0 || nx>h || ny<=0 || ny>w) continue;//出界了舍弃;
		map[nx][ny]=0;
		DFS(nx-drx[i],ny-dry[i],step+1);	//注意若写成step++,后面相应的要写好step--;做好回溯嘛~;
		map[nx][ny]=1;

	}
	return 0;
}
注意:①用 if 判断时,若有多个判断少用else 多用do-while,continue,break 会使代码看起来更清晰。
 ②要么用回溯step++,step--,要么多加一个step变量(vis[]=1,vis[]=0 必须的)。
但是为什么用BFS做 runtime error 了!!真是想不明白 = =!
#include<stdio.h>
#include<string.h>
int w,h,z1;
int map[25*25][25*25],q[25*25],dis[25*25];		//map[树结点序数][一维坐标值]=树结点状态(0,1,2 or 3);
int dx[4]={0,1,0,-1},dy[4]={1,0,-1,0};
int B_search()
{
	memset(q,0,sizeof(q));
	memset(dis,0,sizeof(dis));
	int front=0,rear=1,
		z=z1,x,y,nx,ny,nz;
	q[0]=z,dis[0]=0;
	while(front<rear){
		z=q[front];
		x=z/w;y=z%w;
		for(int i=0;i<4;i++){
			nx=x+dx[i],ny=y+dy[i],nz=nx*w+ny;
			if(map[front][nz]==3) return 1;					//第一步就找到了出口;
			if( nx<=h && nx>0 && ny<=w && ny>0 && map[front][nz]!=1){	//初方向判定;
				do{
					if(map[front][nz]==3) {					//到了出口;
						if(dis[front]+1>10) 
							return -1;
						else
							return dis[front]+1;}
					nx=nx+dx[i];ny=ny+dy[i];nz=nx*w+ny;		//先走后判,走直线;
				}while(nx<=h && nx>0 && ny<=w && ny>0 && map[front][nz]!=1);//未出界也未碰到格挡物继续往前走;
			}
			else continue;
			if(nx>h || nx<=0 || ny>w || ny<=0 ) continue;	//出去了的舍弃;
			//只有碰到了格挡物,才进行记录;
			memcpy(map[rear],map[front],sizeof(map[front]));
			map[rear][nz]=0;
			nx=nx-dx[i];ny=ny-dy[i];nz=nx*w+ny;
			q[rear]=nz;		//printf("%d %d\n",nx,ny);for(int j=1;j<=h;j++){for(int k=1;k<=w;k++) {int p=j*w+k;printf("%d ",map[rear][p]);}printf("\n");}
			dis[rear]=dis[front]+1;		
			rear++;	
		}
		front++;
	}
	return -1;								//未找到,输出-1;
}
int main()
{
	int z;
	while(scanf("%d%d",&w,&h)==2&&w!=0)
	{
		memset(map,0,sizeof(map));
		for(int i=1;i<=h;i++)
			for(int j=1;j<=w;j++){
				z=i*w+j;					//用一维坐标记录;
				scanf("%d",&map[0][z]);
				if(map[0][z]==2)
					z1=z;
			}
		printf("%d\n",B_search());	
	}
	return 0;

}

/*
总结:
①做题之前看清题目意思,按题目要求做!
②BFS易出现runtime error错误,不知道为什么;
③要把所有情况都考虑到,特别是一些特殊元素;
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值