1012. The Best Rank (25)

1012. The Best Rank (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A
题目似乎不是很难,不需要很复杂的算法就能做出来,写程序的时候思路清晰,注意特殊情况,就是分数排序并列的情况,而不是简单的取出数组中的数据作为排名的结果~
感觉这个人写的结题报告不错,以供参考(来源http://tech-wonderland.net/blog/pat-1012-the-best-rank.html)

题目描述:

一个学生拥有英语成绩, 数学成绩, 计算机C语言成绩, 还有三门课程的平均成绩, 让你求得每个学生的单项最好排名.

算法分析:

根据每个学生每个单项排一次序, 统计每个学生单项的最好排名, 后面等级(A > C > M > E)的排序如果对该学生的排名有提升, 更新此学生的最好排名, 否则不变.

注意点:

稍微注意一下PAT的排名规则, 比如总共有5个人, 排名是 A=B > C =D > E, 前两个人并列第一, 那么第三个人的排名应该是3而不是2.   然后第四个人的排名是也是3, 但是第五个人E排名就是5

下面是我的代码,得分为满分,但是代码并不很优美。
 
 
#include<vector>
#include <sstream>
#include<cmath>
#include<iomanip>
#include<iostream>
#include <ctype.h>
#include <stdlib.h>
#include <algorithm>


using namespace std;

struct Student
{
	int stdID;
	int cs[2];//分别存放分数值和该分数值的排名
	int ms[2];
	int es[2];
	int as[2];
};

char GetS(int n);
int main()
{
	int n, m;
	cin >> n >> m;
	Student stds[2001];//排序使用
	vector<Student> students;//最后的二分查找使用

	for (int i = 0; i < n; i++)
	{
		Student std;
		int cs, ms, es;
		cin >> std.stdID >> cs >> ms >> es;
		int av = (cs + ms + es) / 3;
		std.cs[0] = cs;
		std.ms[0] = ms;
		std.es[0] = es;
		std.as[0] = av;
		stds[i]=std;	
		students.push_back(std);
	}	

	//按CS对结构体排序
	for (int i = 1; i < n; i++)
	{		
		Student key = stds[i];
		int j = i - 1;
		while ((j >= 0) && (stds[j].cs[0]<key.cs[0]))			
		{
			stds[j + 1] = stds[j];
			j--;
		}
		stds[j + 1] = key;
	}

	stds[0].cs[1] = 1;

	for (int i = 1; i < n; i++)//结构体中cs数组第二个元素存放它的值
	{
		if (stds[i].cs[0] == stds[i - 1].cs[0])//处理排序并列的情况
		{
			stds[i].cs[1] = stds[i - 1].cs[1];			
		}
		else
		{
			stds[i].cs[1] = i+1;
		}

	}


	//按mS对结构体排序
	for (int i = 1; i < n; i++)
	{
		Student key = stds[i];
		int j = i - 1;
		while ((j >= 0) && (stds[j].ms[0]<key.ms[0]))
		{
			stds[j + 1] = stds[j];
			j--;
		}
		stds[j + 1] = key;
	}

	stds[0].ms[1] = 1;
	for (int i = 1; i < n; i++)//结构体中cs数组第二个元素存放它的值
	{
		if (stds[i].ms[0] == stds[i - 1].ms[0])
		{
			stds[i].ms[1] = stds[i - 1].ms[1];			
		}
		else
		{
			stds[i].ms[1] = i+1;
		}

	}
	

	//按eS对结构体排序
	for (int i = 1; i < n; i++)
	{
		Student key = stds[i];
		int j = i - 1;
		while ((j >= 0) && (stds[j].es[0]<key.es[0]))
		{
			stds[j + 1] = stds[j];
			j--;
		}
		stds[j + 1] = key;
	}

	stds[0].es[1] = 1;
	for (int i = 1; i < n; i++)//结构体中cs数组第二个元素存放它的值
	{
		if (stds[i].es[0] == stds[i - 1].es[0])
		{
			stds[i].es[1] = stds[i - 1].es[1];			
		}
		else
		{
			stds[i].es[1] = i+1;
		}

	}


	//按aS对结构体排序
	for (int i = 1; i < n; i++)
	{
		Student key = stds[i];
		int j = i - 1;
		while ((j >= 0) && (stds[j].as[0]<key.as[0]))
		{
			stds[j + 1] = stds[j];
			j--;
		}
		stds[j + 1] = key;
	}

	stds[0].as[1] = 1;
	for (int i = 1; i < n; i++)//结构体中cs数组第二个元素存放它的值
	{
		if (stds[i].as[0] == stds[i - 1].as[0])
		{
			stds[i].as[1] = stds[i - 1].as[1];			
		}
		else
		{
			stds[i].as[1] = i+1;
		}

	}

	

	int stdnums[2001] = {0};
	for (int i = 0; i < m; i++)
	{
		cin >> stdnums[i];
	}

	for (int i = 0; i < m; i++)//对每一个ID进行处理
	{
		int stdID = stdnums[i];
		int flag = 0;
		int max = 0;
		int acme[4] = { 0 };//按ACME的顺序,将分数存放到该数组中
		for (int j = 0; j < n; j++)
		{
			if (stdID == stds[j].stdID)//如果找到了对应的ID
			{				
				acme[0] = stds[j].as[1];
				acme[1] = stds[j].cs[1];
				acme[2] = stds[j].ms[1];
				acme[3] = stds[j].es[1];
				
				for (int k = 0; k < 4; k++)
				{
					if (acme[k]<acme[max])
					{
						max = k;
					}
				}
				flag = 1;				
				break;
			}			
		}
		if (flag == 1)
		{
			cout << acme[max] << " " << GetS(max)<<endl;
		}
		else
		{
			cout << "N/A" << endl;
		}
	}

	return 0;
}

char GetS(int n)//实现对应的顺序输出字母
{
	switch (n)
	{
		case 0:return 'A'; break;
		case 1:return 'C'; break;
		case 2:return 'M'; break;
		case 3:return 'E'; break;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值