[PAT]1012. The Best Rank (25)@Java

1012. The Best Rank (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A



package go.jacob.day829;

import java.util.Arrays;
import java.util.Collection;
import java.util.Comparator;
import java.util.HashMap;
import java.util.List;
import java.util.Map;
import java.util.Scanner;

public class Demo2 {
	// 建立map,保存ID和学生的映射关系
	static Map<String, Student> map;
	static Scanner sc;

	public static void main(String[] args) {
		sc = new Scanner(System.in);
		int N = sc.nextInt();
		int M = sc.nextInt();
		Student[] stu = new Student[N];
		// 初始化
		init(stu, N);

		// solve函数用来计算每个学生的bestRank和bestCourse
		for (int i = 0; i < N; i++) {
			solve(stu[i], N);
		}

		for (int i = 0; i < N; i++) {
			map.put(stu[i].ID, stu[i]);
		}
		String[] IDs = new String[M];
		for (int i = 0; i < M; i++) {
			IDs[i] = sc.next();
		}

		for (int i = 0; i < M; i++) {
			if (map.containsKey(IDs[i])) {
				Student student = map.get(IDs[i]);
				System.out.println(student.bestRank + " " + student.bestCourse);
			} else
				System.out.println("N/A");
		}

	}

	/*
	 * 初始化学生,各个科目排序完成的数组
	 */
	private static void init(Student[] stu, int N) {
		map = new HashMap<String, Student>();
		Student.cSeq = new Integer[N];
		Student.mSeq = new Integer[N];
		Student.eSeq = new Integer[N];
		Student.aSeq = new Integer[N];
		for (int i = 0; i < N; i++) {
			String ID = sc.next();
			int c = sc.nextInt(), m = sc.nextInt(), e = sc.nextInt();
			stu[i] = new Student(ID, c, m, e);
			map.put(stu[i].ID, stu[i]);
		}
		Collection<Student> lists=map.values();
		int i=0;
		for(Student s:lists){
			Student.cSeq[i]=s.scores[0];
			Student.mSeq[i]=s.scores[1];
			Student.eSeq[i]=s.scores[2];
			Student.aSeq[i]=s.scores[3];
			i++;
		}
		
		
		// 自定义比较器,实现从大到小排序
		Comparator<Integer> c = new Comparator<Integer>() {
			@Override
			public int compare(Integer o1, Integer o2) {
				return o2 - o1;
			}
		};
		Arrays.sort(Student.cSeq, c);
		Arrays.sort(Student.mSeq, c);
		Arrays.sort(Student.eSeq, c);
		Arrays.sort(Student.aSeq, c);
	}

	private static void solve(Student stu, int N) {
		int min = 5;
		for (int i = 0; i < N; i++) {
			// 优先级A>C>M>E
			if (stu.scores[3] == Student.aSeq[i] && i < min) {
				stu.bestCourse = "A";
				stu.bestRank = i;
				min = i;
				break;
			}
			if (stu.scores[0] == Student.cSeq[i] && i < min) {
				stu.bestCourse = "C";
				stu.bestRank = i;
				min = i;
				break;
			}
			if (stu.scores[1] == Student.mSeq[i] && i < min) {
				stu.bestCourse = "M";
				stu.bestRank = i;
				min = i;
				break;
			}

			if (stu.scores[2] == Student.eSeq[i] && i < min) {
				stu.bestCourse = "E";
				stu.bestRank = i;
				min = i;
				break;
			}
		}
		stu.bestRank = min + 1;
	}

	static class Student {
		public static Integer[] cSeq;
		public static Integer[] mSeq;
		public static Integer[] eSeq;
		public static Integer[] aSeq;
		String ID;
		int scores[] = new int[4];// 记录每个科目分数
		int bestRank;// 记录最高排名
		String bestCourse;// 记录最高排名课程

		public Student(String ID, int a, int b, int c) {
			super();
			this.ID = ID;
			scores[0] = a;
			scores[1] = b;
			scores[2] = c;
			scores[3] = (a + b + c) / 3;
			// 初始化为-1

		}
	}
}

/*
 * 
 * 5 6 310101 98 85 88 310102 70 95 88 310103 82 87 94 310104 91 91 91 310105 85
 * 90 90 310101 310102 310103 310104 310105 999999
 */


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值