HDU 4738Caocao's Bridges 邻接表tarjan 割桥

Caocao's Bridges

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn't give up. Caocao's army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao's army could easily attack Zhou Yu's troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao's army could be deployed very conveniently among those islands. Zhou Yu couldn't stand with that, so he wanted to destroy some Caocao's bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn't be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.


Input
There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.


Output
For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn't succeed any way, print -1 instead.


Sample Input
3 3
1 2 7
2 3 4
3 1 4
3 2
1 2 7
2 3 4
0 0


Sample Output
-1
4


Source

2013 ACM/ICPC Asia Regional Hangzhou Online

题意: 给定n个岛和m条桥。每座桥给出连接的两个岛和桥上的士兵数。现只能炸一座桥。

若该图为强连通图则输出-1,反之求最少炸药数==桥上士兵数 。

1:有重边~一开始没考虑!!附上邻接矩阵的“WA”代码  与 邻接表的AC代码; 

2:若桥上士兵数为0,也要一个炸弹,输出1;

3:若原图不连通,即多个连通子图,则不用炸弹,输出0。

邻接表AC代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#define min(a,b) (a>b?b:a)
#define CLR(arr,x) memset(arr,x,sizeof(arr))
#define FOR(I,J) for(int i=I ; i<J ; ++i)
using namespace std;
const int maxn = 1000 + 100 ;
const int Inf = 1<<30 ;
int Dfn[maxn] , Low[maxn] ;
int Fa[maxn] ;
int Cost , Ver;
int Times , Num ;
int n , m ;
void Init () {
    CLR(Fa,-1) ;
    CLR(Dfn, 0) ;
    Times = Num = 0 ;
    Cost = Inf ;
    Ver = 0 ;
}
struct Edge{
    int v , w ;
    int next ;
} E[maxn*maxn] ;
void AddEdge(int from , int to  ,int w ) {
    E[Num].v = to ;
    E[Num].w = w ;
    E[Num].next = Fa[from] ;
    Fa[from] = Num++ ;

    E[Num].v = from ;
    E[Num].w = w;
    E[Num].next = Fa[to] ;
    Fa[to] = Num++ ;
}

void Tarjan( int u , int Number) {
    Dfn[u] = Low[u] = ++Times ;
    for( int e = Fa[u] ; e != -1 ; e = E[e].next ) {
        int v = E[e].v ;
        if( (Number^1) == e ) {continue ; }
        if( !Dfn[v] ) {
            Tarjan(v , e) ;
            Low[u] = Low[u] > Low[v] ? Low[v] : Low[u] ;
            if( Low[v] > Dfn[u] ) {
                Cost = Cost > E[e].w ? E[e].w : Cost ;
            }
        }
        else Low[u] = Low[u] > Dfn[v] ? Dfn[v] : Low[u] ;
    }
}
int main() {
    int Island1 ,Island2 , People ;
    while(~scanf("%d%d",&n,&m)&&(n||m)) {
            Init() ;
        FOR(0,m) {
            scanf("%d%d%d",&Island1,&Island2,&People) ;
            AddEdge(Island1, Island2,People) ;
        }
        Tarjan(1,-1) ;
        if( Times < n ) { printf("0\n") ;}
        else if( Cost == Inf) printf("-1\n") ;
        else if( !Cost ) {printf("1\n") ;}
        else printf("%d\n",Cost) ;

    }
    return 0 ;
}

 
 



邻接矩阵WA代码  ~~~

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <cstdlib>
using namespace std;
const int maxn = 1000+100 ;
const int Inf = 1<<30 ;
vector<int>Map[maxn] ;
int Val[maxn][maxn] ;
int Dfn[maxn] , Low[maxn] ;
int Fa[maxn] ;
int Nbridge , Times ;
bool Is_bridge[maxn] ,Mapp[maxn][maxn] ;
int n , m ;
void init() {
    memset(Dfn,0,sizeof(Dfn)) ;
    memset(Is_bridge, 0 ,sizeof(Is_bridge)) ;
    memset( Fa, 0  ,sizeof(Fa)) ;
    memset(Val,0, sizeof(Val)) ;
    memset(Mapp,0,sizeof(Mapp)) ;
    Nbridge = Times = 0 ;
    for( int i = 0 ; i <= n ; ++i ) {
        Map[i].clear() ;
    }
}
int tarjan(int u , int fa ) {
    Dfn[u] = Low[u] = ++Times ;
    for( int i = 0 ; i < Map[u].size() ; ++i ) {
        int v  =Map[u][i] ;
        if(!Dfn[v]){
            Fa[v] = u ;
            tarjan(v,u) ;
            if( Low[v] > Dfn[u] )  {
                Nbridge++;
                Is_bridge[v] = true ;
            }
            Low[u] = Low[u] > Low[v] ? Low[v] : Low[u] ;
        }
        else if( v != fa ) {
            Low[u] = Low[u] > Dfn[v] ? Dfn[v] : Low[u] ;
        }
    }
    return Times ;
}
int main() {
    while(~scanf("%d%d",&n,&m)&&(n||m)) {
        init() ;
        int  island1 , island2 , people ;
        for( int i = 0; i < m ; ++i ) {
            scanf("%d%d%d",&island1,&island2,&people) ;
            if(!Mapp[island1][island2]){
                Map[island1].push_back(island2) ;
                Map[island2].push_back(island1) ;
                Val[island1][island2] = Val[island2][island1] = people ;
            }
            Mapp[island1][island2] = Mapp[island2][island1] = true ;
        }
        int Num = tarjan(1,-1)  ;
        if( Num < n ) {printf("0\n") ; continue ; }
        int Minn = Inf ;
        if( !Nbridge ) { printf("-1\n") ;continue ;}
            for( int i = 1 ; i <= n ; ++i ) {
                if( Is_bridge[i] ) {
                    Minn = Val[i][Fa[i]] > Minn ? Minn : Val[i][Fa[i]] ;
                }
            }
            if( !Minn ) Minn = 1 ;
            printf("%d\n",Minn) ;
    }
    return 0 ;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值